I - Red and Black

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
Sample Input
6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0
Sample Output
45
59
6
13


//深搜模板题
#include <stdio.h>
#include <string.h>
int n,m,ans;
char map[30][30];
int to[4][2] = {{1,0},{0,1},{-1,0},{0,-1}};
void dfs(int i,int j)
{
    ans++;
    map[i][j] = '#';
    for(int k = 0; k<4; k++)
    {
        int x = i+to[k][0];
        int y = j+to[k][1];
        if(x<n && y<m && x>=0 && y>=0 && map[x][y] == '.')
            dfs(x,y);
    }
    return;
}
int main()
{
    int i,j,sx,sy;
    while(~scanf("%d%d%*c",&m,&n))
    {
        if(m == 0 && n == 0)
            break;
        for(i = 0; i<n; i++)
        {
            for(j = 0; j<m; j++)
            {
                scanf("%c",&map[i][j]);
                if(map[i][j] == '@')
                {
                    sx = i;
                    sy = j;
                }
            }
            getchar();
        }
        ans = 0;
        dfs(sx,sy);
        printf("%d\n",ans);
    }
    return 0;
}
//深搜模板题


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
### 回答1: 我不熟悉Java语言,不过我可以试着用Java描述一棵树:Tree tree = new Tree("Red Leaves", "Black Branches"); tree.addLeaves("Red Leaves"); tree.addBranches("Black Branches"); ### 回答2: 可以使用Java语言编写带有红叶和黑色树干的树。以下是实现此功能的示例代码: ```java import java.awt.Color; import java.awt.Graphics; import javax.swing.JFrame; import javax.swing.JPanel; public class RedLeafBlackBranchTree extends JPanel { private static final long serialVersionUID = 1L; private final int WIDTH = 800; private final int HEIGHT = 800; public RedLeafBlackBranchTree() { setBackground(Color.WHITE); } @Override public void paintComponent(Graphics g) { super.paintComponent(g); drawTree(g, WIDTH / 2, HEIGHT - 50, 100, -90); } private void drawTree(Graphics g, int x1, int y1, double length, double angle) { if (length < 10) { return; } int x2 = x1 + (int) (Math.cos(Math.toRadians(angle)) * length); int y2 = y1 + (int) (Math.sin(Math.toRadians(angle)) * length); g.setColor(Color.BLACK); g.drawLine(x1, y1, x2, y2); drawTree(g, x2, y2, length * 0.7, angle - 30); drawTree(g, x2, y2, length * 0.7, angle + 30); for (int i = 0; i < 15; i++) { g.setColor(Color.RED); g.fillOval(x2 - 8, y2 - 8, 16, 16); } } public static void main(String[] args) { JFrame frame = new JFrame("Red Leaf Black Branch Tree"); frame.setDefaultCloseOperation(JFrame.EXIT_ON_CLOSE); frame.setSize(800, 800); frame.add(new RedLeafBlackBranchTree()); frame.setLocationRelativeTo(null); frame.setVisible(true); } } ``` 运行该程序,将显示一个具有红叶和黑色树枝的树。 ### 回答3: public class Tree { public static void main(String[] args) { drawTree(); } private static void drawTree() { String trunk = "BBBBBBBBBBB"; String branch = "BBBBBBBB"; String leaves = "RRR"; for (int i = 0; i < 4; i++) { System.out.printf("%" + (11 - i) + "s\n", trunk); } for (int i = 0; i < 4; i++) { System.out.printf("%" + (11 - i) + "s\n", branch); } for (int i = 0; i < 3; i++) { System.out.printf("%" + (12 - i) + "s\n", leaves); } } } 这段代码使用Java语言绘制一棵有红叶子和黑树枝的树。树干使用字符串"BBBBBBBBBBB"表示,树枝使用字符串"BBBBBBBB"表示,树叶使用字符串"RRR"表示。通过循环打印字符串,树的形状就被打印出来。树干共有4层,树枝共有4层,树叶共有3层。具体绘制过程是通过循环控制字符串的右对齐输出。输出结果就是一棵有红叶子和黑树枝的树的形状。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值