UVA 133(循环链表)

C - The Dole Queue
Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu

Description

Download as PDF


 The Dole Queue 

In a serious attempt to downsize (reduce) the dole queue, The New National Green Labour Rhinoceros Party has decided on the following strategy. Every day all dole applicants will be placed in a large circle, facing inwards. Someone is arbitrarily chosen as number 1, and the rest are numbered counter-clockwise up to N (who will be standing on 1's left). Starting from 1 and moving counter-clockwise, one labour official counts off k applicants, while another official starts from N and moves clockwise, counting m applicants. The two who are chosen are then sent off for retraining; if both officials pick the same person she (he) is sent off to become a politician. Each official then starts counting again at the next available person and the process continues until no-one is left. Note that the two victims (sorry, trainees) leave the ring simultaneously, so it is possible for one official to count a person already selected by the other official.

Input

Write a program that will successively read in (in that order) the three numbers (N, k and m; k, m > 0, 0 < N < 20) and determine the order in which the applicants are sent off for retraining. Each set of three numbers will be on a separate line and the end of data will be signalled by three zeroes (0 0 0).

Output

For each triplet, output a single line of numbers specifying the order in which people are chosen. Each number should be in a field of 3 characters. For pairs of numbers list the person chosen by the counter-clockwise official first. Separate successive pairs (or singletons) by commas (but there should not be a trailing comma).

Sample input

10 4 3
0 0 0

Sample output

tex2html_wrap_inline34 4 tex2html_wrap_inline34 8, tex2html_wrap_inline34 9 tex2html_wrap_inline34 5, tex2html_wrap_inline34 3 tex2html_wrap_inline34 1, tex2html_wrap_inline34 2 tex2html_wrap_inline34 6, tex2html_wrap_inline50 10, tex2html_wrap_inline34 7

where tex2html_wrap_inline50 represents a space.


题意:一个循环的圈,由两个人从头尾开始查找,分别将第m,第n的人删除,(两人是同时进行的),即是数完了才删除的,遇到相同的只输出一个,否则都输出,然后重新开始数,直至全部输完为止。直接用循环链表模拟即可,需要注意要删除的两个人相邻的情况,需要特殊处理,代码如下

#include<cstdio>
#include<cstring>
#include<algorithm>
#define front Front
int N,M,K,num[21],next[21],front[21],ans[21];
int main()
{
    while(~scanf("%d%d%d",&N,&M,&K)&&(M+N+K))
    {
        for(int i=0;i<N;i++)
        {
            num[i]=i+1;
            next[i]=i+1;
            front[i]=i-1;
        }
        front[0]=N-1;
        next[N-1]=0;
        int count=0,head=0,rear=N-1,t1=1,t2=1,p=N-1,q=0;///p,q,分别为head和rear的前一节点
        while(count<N)
        {
            while(t1<M){p=head;head=next[head];t1++;}
            while(t2<K){q=rear;rear=front[rear];t2++;}
            t1=t2=1;
            if(num[head]!=num[rear])
            {
                count+=2;
                printf("%3d%3d",num[head],num[rear]);
                if(count<N)putchar(',');
            }
            else///相等只打印一个
            {
                count+=1;
                printf("%3d",num[head]);
                if(count<N)putchar(',');
            }
            if(next[head]==rear)///head的后驱等于rear
            {
                next[p]=next[rear];
                front[q]=front[head];
                head=next[rear];
                rear=front[head];
            }
            else if(front[head]==rear)///head的前驱等于rear(一定要注意判断这些情况)
            {
                next[front[rear]]=next[head];
                front[next[head]]=front[rear];
                head=next[head];
                rear=front[rear];
            }
            else///head ,rear不相邻
            {
                next[p]=next[head];
                front[next[head]]=front[head];
                front[q]=front[rear];
                next[front[rear]]=next[rear];
                head=next[head];
                rear=front[rear];
            }
        }
        printf("\n");
    }
    return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值