Aladdin and the Flying Carpet

题目:

It's said that Aladdin had to solve seven mysteries before getting the Magical Lamp which summons a powerful Genie. Here we are concerned about the first mystery.

Aladdin was about to enter to a magical cave, led by the evil sorcerer who disguised himself as Aladdin's uncle, found a strange magical flying carpet at the entrance. There were some strange creatures guarding the entrance of the cave. Aladdin could run, but he knew that there was a high chance of getting caught. So, he decided to use the magical flying carpet. The carpet was rectangular shaped, but not square shaped. Aladdin took the carpet and with the help of it he passed the entrance.

Now you are given the area of the carpet and the length of the minimum possible side of the carpet, your task is to find how many types of carpets are possible. For example, the area of the carpet 12, and the minimum possible side of the carpet is 2, then there can be two types of carpets and their sides are: {2, 6} and {3, 4}.

Input

Input starts with an integer T (≤ 4000), denoting the number of test cases.

Each case starts with a line containing two integers: a b (1 ≤ b ≤ a ≤ 1012) where a denotes the area of the carpet and bdenotes the minimum possible side of the carpet.

Output

For each case, print the case number and the number of possible carpets.

Sample Input

2

10 2

12 2

Sample Output

Case 1: 1

Case 2: 2

 

题意:

给两个数x,y,求满足c*d==x且c>=y且d>=y的c,d二元组对数,(c,d)和(d,c)属于同一种情况;

 

思路:

根据唯一分解定理,先将x唯一分解,则a的所有正约数的个数为sum = (1 + x1) * (1 + x2) *...(1 + xi),这里的xi是素因子的指数,因为题目说了不会存在c==d的情况,因此sum要除2,去掉重复情况,然后枚举小于y的x的约数,拿sum减掉就可以了;

 

 

#include<stdio.h>
#include<string.h>
#include<math.h>
long long a[1000100],prime[1000100],ss;
void is_prime()
{
    memset(a,0,sizeof(a));
    ss=0;
    for(long long i=2; i<=1000100; i++)
    {
        if(!a[i])
        {
            prime[ss++]=i;
            for(long long j=i+i;j<=1000100;j=j+i)
            {
                a[j]=1;
            }
        }
    }
}
long long run(long long x)
{
    long long s=1,i=0,n;
    while(prime[i]<x&&i<ss)
    {
        n=0;
        if(x%prime[i]==0)
        {
            while(x%prime[i]==0)
            {
                x=x/prime[i];
                n++;
            }
        }
        s=s*(n+1);
        i++;
    }
    if(x>1)
        s=s*2;
    return s;
}

int main()
{
    is_prime();
    int n,k=1;
    scanf("%d",&n);
    while(n--)
    {
        long long x,y,sum=0,ans;
        scanf("%lld%lld",&x,&y);
        if(y>=sqrt(x))
            sum=0;
        else
        {
            sum=run(x)/2;
            ans=0;
            for(long long i=1;i<y;i++)
                if(x%i==0)
                    ans++;
            sum=sum-ans;
        }
        printf("Case %d: %lld\n",k++,sum);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值