Aladdin and the Flying Carpet 唯一分解定理

 

It's said that Aladdin had to solve seven mysteries before getting the Magical Lamp which summons a powerful Genie. Here we are concerned about the first mystery.

Aladdin was about to enter to a magical cave, led by the evil sorcerer who disguised himself as Aladdin's uncle, found a strange magical flying carpet at the entrance. There were some strange creatures guarding the entrance of the cave. Aladdin could run, but he knew that there was a high chance of getting caught. So, he decided to use the magical flying carpet. The carpet was rectangular shaped, but not square shaped. Aladdin took the carpet and with the help of it he passed the entrance.

Now you are given the area of the carpet and the length of the minimum possible side of the carpet, your task is to find how many types of carpets are possible. For example, the area of the carpet 12, and the minimum possible side of the carpet is 2, then there can be two types of carpets and their sides are: {2, 6} and {3, 4}.

 

Input

Input starts with an integer T (≤ 4000), denoting the number of test cases.

Each case starts with a line containing two integers: a b (1 ≤ b ≤ a ≤ 1012) where a denotes the area of the carpet and b denotes the minimum possible side of the carpet.

 

 

Output

For each case, print the case number and the number of possible carpets.

Sample Input

2

10 2

12 2

Sample Output

Case 1: 1

Case 2: 2

 

题意:给出矩形飞毯(想坐)面积,给出最小边长,求可以形成不同形状的矩形个数;

用到算术基本定理:

1. 每一个数n都能被分解为:n=p1^a1*p2^a2*^p3^a3……pn^an(p为素数) 的形式;
2. n的正因子数的个数sum可以表示为:sum=(1+a1)*(1+a2)*(1+a3)……(1+an);

定理证明,应用和推广:下方传送门

百度百科算数基本定理

解题思路:①打表;②唯一分解定理的模板;

代码解释都在注释里了

 

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#define maxn 1000005
using namespace std;

bool ss[maxn];
long long sum[maxn],sumary=0;

void primefound()//素数打表 
{
    for(int i=2;i<=maxn;i++)
    {
    	if(ss[i]==false)
    	{
    		sum[++sumary]=i;
			//注意这道题打表的作用,用sum数组存下所有素数 
			for(int j=i;j<=maxn;j+=i)
    		{
    			ss[j]=true;
			}
		}
	}
}
long long only(long long n)//唯一分解定理公式模板
{
    long long cnt,divisor=1;
    //for(int i=1;i<=sumary&&sum[i]<=n;i++)经提醒已修改原超时代码
    for(int i=1;i<=sumary&&sum[i]*sum[i]<=n;i++)
    {
        if(n%sum[i]==0)
        {
            cnt=0;
            while(n%sum[i]==0)
            {
                cnt++;
                n/=sum[i];
            }
            divisor*=(cnt+1);/// 
        }
    }
    if(n > 1)
    	divisor*=2;
    //大于1就乘2,因为打表只能打到1e6,数据给的到了1e12
	//所以在大于1e6时还会有另一半因子 
	//比如1e3对应的1e9 
    return divisor;
}
int main()
{
	primefound();
	int n;
	scanf("%d",&n);
	for(int k=1;k<=n;k++)
	{
		long long area,mini;
		scanf("%lld%lld",&area,&mini);
		if(area/mini<mini)
		//不成立条件 矩形不存在
		{
		    printf("Case %d: %lld\n",k,0);
            continue;
		}
		long long ans=only(area)/2;
		for(int i=1;i<mini;i++)
		{
			if(area%i==0)//除掉小于最小边长mini的错误数据 
				ans--; 
		}
		printf("Case %d: %lld\n",k,ans);
	}
	return 0;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值