pat甲级1043 静态二叉树(BST)

1043 Is It a Binary Search Tree (25 分)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.

Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in a line YES if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or NO if not. Then if the answer is YES, print in the next line the postorder traversal sequence of that tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

7
8 6 5 7 10 8 11

Sample Output 1:

YES
5 7 6 8 11 10 8

Sample Input 2:

7
8 10 11 8 6 7 5

Sample Output 2:

YES
11 8 10 7 5 6 8

Sample Input 3:

7
8 6 8 5 10 9 11

Sample Output 3:

NO

题目大意:给出BST树的先序遍历,让你判断这是BST还是镜像BST的先序,如果都不是,输出“NO",如果是,则输出对应的后序遍历;

由于指针学得不是很好,就尝试把《算法笔记》上用的指针树,改为静态二叉链表。

大体思路:把这个输入的数组,用insert方法,形成一个BST,root保存的是根节点,然后对这个形成的树分别进行先序遍历,和先序镜像遍历;如果原数组和先序遍历后的数组相等,则说明原数组是BST,如果原数组和先序镜像遍历后的数组相等,则说明是镜像BST;

有两个测试点答案错误,过段时间再回头看看吧; 

反思:刚开始把index放在了Node[index]后面,这就导致了root=index+1,root变为第二个元素了,就不再是根节点。

#include <iostream>
#include "vector"
#include "algorithm"

using namespace std;
struct node{
    int data;
    int lchild,rchild;
}Node[1010];
int index = 0;
int newNode(int v){
    index++;   //要先对index自加,否则root节点不是第一个
    Node[index] = {v,-1,-1};
    return index;
}
void insert(int &root,int x){
    if (root == -1){
        root = newNode(x);
        return;
    }
    if (x >= Node[root].data) insert(Node[root].rchild,x);
    else insert(Node[root].lchild,x);
}
void preorder(int root,vector<int> &vi){
    if (root == -1) return;
    vi.push_back(Node[root].data);
    preorder(Node[root].lchild,vi);
    preorder(Node[root].rchild,vi);
}
void preorderMirror(int root,vector<int> &vi){
    if (root == -1) return;
    vi.push_back(Node[root].data);
    preorderMirror(Node[root].rchild,vi);
    preorderMirror(Node[root].lchild,vi);
}
void postorder(int root,vector<int> &vi){
    if (root == -1) return;
    postorder(Node[root].lchild,vi);
    postorder(Node[root].rchild,vi);
    vi.push_back(Node[root].data);
}
void postMirrorOrder(int root,vector<int> &vi){
    if (root == -1) return;
    postMirrorOrder(Node[root].rchild,vi);
    postMirrorOrder(Node[root].lchild,vi);
    vi.push_back(Node[root].data);
}
int main() {
    int n, temp;
    cin >> n;
    vector<int> preM, pre, postM, post, oringin;
    int root = -1;
    for (int i = 0; i < n; ++i) {
        cin >> temp;
        oringin.push_back(temp);
        insert(root, temp);
    }
    preorder(root, pre);
    preorderMirror(root, preM);
    if (oringin == pre) {
        postorder(root, post);
        printf("YES\n");
        for (int i = 0; i < post.size(); ++i) {
            if (i == 0) printf("%d", post[0]);
            else printf(" %d", post[i]);
        }
    } else if (oringin == preM) {
        postMirrorOrder(root, postM);
        printf("YES\n");
        for (int i = 0; i < postM.size(); ++i) {
            if (i == 0) printf("%d", postM[0]);
            else printf(" %d", postM[i]);
        }
    } else printf("No\n");
}

更新:

代码后面有点冗余了,懒得改了。

不知道为什么像上面那样直接遍历不行,把左右节点交换后就可以了,有懂的吗?

#include <iostream>
#include "vector"
using namespace std;
vector<int> tree;
struct node{
    int data;
    int lchild,rchild;
}Node[1500];
int index = 0;
vector<int> pre,premirror,post,postmirror;
int newnode(int ans){
    index++;
    Node[index]={ans,-1,-1};
    return index;
}
void insert(int &root,int x){
    if (root == -1){
        root = newnode(x);
        return;
    }
    if (x >= Node[root].data) insert(Node[root].rchild,x);
    else insert(Node[root].lchild,x);
}
void preorder(int root,vector<int> &vi){
    if (root == -1) return;
    vi.push_back(Node[root].data);
    preorder(Node[root].lchild,vi);
    preorder(Node[root].rchild,vi);
}
void postorder(int root,vector<int> &vi){
    if (root == -1) return;
    postorder(Node[root].lchild,vi);
    postorder(Node[root].rchild,vi);
    vi.push_back(Node[root].data);
}
int main() {
    int n,temp;
    scanf("%d",&n);
    int root = -1;  //-1
    for (int i = 0; i < n; ++i) {
        scanf("%d",&temp);
        tree.push_back(temp);
        insert(root,temp);
    }
    preorder(root,pre);
    if (tree == pre){
        printf("YES\n");
        postorder(root,post);
        for (int i = 0; i < post.size(); ++i) {
            if (i==0) printf("%d",post[0]);
            else printf(" %d",post[i]);
        }
        return 0;
    }
    for(int i=1;i<n+1;++i){
        swap(Node[i].lchild,Node[i].rchild);
    }
    pre.clear();
    preorder(root,pre);
     if (tree == pre){
        printf("YES\n");
        postorder(root,post);
        for (int i = 0; i < post.size(); ++i) {
            if (i==0) printf("%d",post[0]);
            else printf(" %d",post[i]);
        }
        return 0;
    }
    printf("NO\n");
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值