pat甲级1102 Invert a Binary Tree (树的遍历)

1102 Invert a Binary Tree (25 分)

The following is from Max Howell @twitter:

Google: 90% of our engineers use the software you wrote (Homebrew), but you can't invert a binary tree on a whiteboard so fuck off.

Now it's your turn to prove that YOU CAN invert a binary tree!

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node from 0 to N−1, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in the first line the level-order, and then in the second line the in-order traversal sequences of the inverted tree. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:

8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6

Sample Output: 

3 7 2 6 4 0 5 1
6 5 7 4 3 2 0 1

题目给出了一个二叉树每个节点的左右节点,让我们写出这个二叉树反转后的层序遍历和中序遍历。

把二叉树反转,就是把原有的左右节点交换,左变右,右变左 。所以我们在输入的时候直接把数据作为右、左节点建树就好了。

建完树后就是简单的层序和中序遍历了,这里犯了一个小错误,在层序遍历时把要push的节点一直写为了最开始的根节点root,可能是经常迭代,弄混了。

找根节点:在输入数据中没有出现的节点就是根节点,因为它不是任何节点的左右节点,所以不会出现。题目数据没有出现3,3就是根节点

#include <iostream>
#include "vector"
#include "queue"
using namespace std;
int n;
int notroot[20];
vector<int> level,in;
struct node{
    int left,right;
}Node[20];
void levelOrder(int root){
    queue<int> m;
    m.push(root);
    while (!m.empty()){
        int top = m.front();
        m.pop();
        level.push_back(top);
        if (Node[top].left != -1) m.push(Node[top].left);
        if (Node[top].right != -1) m.push(Node[top].right);
    }
}
void inorder(int root){
    if (root == -1) return;
    inorder(Node[root].left);
    in.push_back(root);
    inorder(Node[root].right);
}
int main() {
    scanf("%d\n",&n);
    char a[1],b[1];
    string str;
    for (int i = 0; i < n; ++i) {
        getline(cin,str);
        if (isdigit(str[0])) Node[i].right = str[0]-'0',notroot[str[0]-'0']=1;
        else Node[i].right = -1;
        if (isdigit(str[2])) Node[i].left = str[2]-'0',notroot[str[2]-'0']=1;
        else Node[i].left = -1;
    }
    int i =0;
    while (i<n && notroot[i] != 0) i++;
    levelOrder(i);
    inorder(i);
    for (int i = 0; i < n; ++i) {
        if (i==0) printf("%d",level[0]);
        else printf(" %d",level[i]);
    }
    printf("\n");
    for (int i = 0; i < n; ++i) {
        if (i==0) printf("%d",in[0]);
        else printf(" %d",in[i]);
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值