杭电1005

Number Sequence
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 45754 Accepted Submission(s): 10082
Problem Description
A number sequence is defined as follows:
f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.
Given A, B, and n, you are to calculate the value of f(n).
Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
Output
For each test case, print the value of f(n) on a single line.
Sample Input

1 1 3  1 2 10  0 0 0

Sample Output

2  5


Author
CHEN, Shunbao
Source
ZJCPC2004 
Recommend
JGShining


刚开始用递归做,提交的结果是Memory Limit Exceeded,上百度查了,应该是栈溢出,也就是内存限制超出。以后遇上超时或超内存的题目无法解决可以尝试找循环。本题就是一个循环题目。f(n)对7求模,所以他只有0,1,2,3,4,5,6这7中情况,但是给定的公式中有A,B对f(n)进行限制,所以有7*7=49种情况,49个数一个循环。

#include<stdio.h>

int main()
{
    int a[100];
	int i,j,k,d,b,n;
	
	while (scanf ("%d%d%d",&d,&b,&n) != EOF)
	{
		if (d==0&&b==0&&n==0)break;
		a[0]=1;
		a[1]=1;
		for (i=2; i<=48; i++)
		{
			a[i]=(d*a[i-1]+b*a[i-2])%7;
		}
		n=n%48;
		
		printf("%d\n",a[n-1]);
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值