Spring-1-E Game(HDU 5011)解题报告及测试数据

Game

Time Limit:1000MS     Memory Limit:65536KB

Description

Here is a game for two players. The rule of the game is described below:

● In the beginning of the game, there are a lot of piles of beads.

● Players take turns to play. Each turn, player choose a pile i and remove some (at least one) beads from it. Then he could do nothing or split pile i into two piles with a beads and b beads.(a,b > 0 and a + b equals to the number of beads of pile i after removing)

● If after a player's turn, there is no beads left, the player is the winner.

Suppose that the two players are all very clever and they will use optimal game strategies. Your job is to tell whether the player who plays first can win the game.

Input

There are multiple test cases. Please process till EOF.

For each test case, the first line contains a postive integer n(n < 10 5) means there are n piles of beads. The next line contains n postive integer, the i-th postive integer a i(a i < 2 31) means there are a i beads in the i-th pile.

Output

For each test case, if the first player can win the game, ouput "Win" and if he can't, ouput "Lose"

Sample Input

1

1

2

1 1

3

1 2 3

 

Sample Output

Win

Lose

Lose 

题解:

  1. 这道题是典型的Nim游戏,与Nim游戏不同的是该题中除了至少拿走一颗珠子以外,还可以将该堆剩下的珠子分为两堆,其实这对游戏的胜负判断是没有影响的。因为至少拿走了一颗珠子,那么xor求和,之前为0,拿走珠子以后,无论是否将剩下的该堆珠子分为两堆,此时的xor和必不为零,反之亦然。

  2. 关于Nim游戏,已经有大量的解释,在此略过。  

​以下是代码:

#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
#include <algorithm>
#include <cctype>
#include <sstream>
#include <queue>
using namespace std;
 
#define F(i,s,e) for(int i = s;i<e;i++)
#define ss(x) scanf("%d",&x)
#define write() freopen("1.in","r",stdin)
#define W(x) while(x)
 
int main(){
    //write();
    int n,t,sum;
    W(ss(n)!=EOF){
        sum=0;
        W(n--){
            ss(t);
            sum^=t;//对所有的输入xor求和
        }
        if(sum)printf("Win\n");
        else printf("Lose\n");//和为零,则先手必输
    }
}

  

转载于:https://www.cnblogs.com/gzdaijie/p/4311730.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值