Spring-2-A Magic Grid(SPOJ AMR11A)解题报告及测试数据

Magic Grid

Time Limit:336MS     Memory Limit:0KB     64bit IO Format:%lld & %llu

Description

Thanks a lot for helping Harry Potter in finding the Sorcerer's Stone of Immortality in October. Did we not tell you that it was just an online game ? uhhh! now here is the real onsite task for Harry. You are given a magrid S ( a magic grid ) having R rows and C columns. Each cell in this magrid has either a Hungarian horntail dragon that our intrepid hero has to defeat, or a flask of magic potion that his teacher Snape has left for him. A dragon at a cell (i,j) takes away |S[i][j]| strength points from him, and a potion at a cell (i,j) increases Harry's strength by S[i][j]. If his strength drops to 0 or less at any point during his journey, Harry dies, and no magical stone can revive him.

 

Harry starts from the top-left corner cell (1,1) and the Sorcerer's Stone is in the bottom-right corner cell (R,C). From a cell (i,j), Harry can only move either one cell down or right i.e., to cell (i+1,j) or cell (i,j+1) and he can not move outside the magrid. Harry has used magic before starting his journey to determine which cell contains what, but lacks the basic simple mathematical skill to determine what minimum strength he needs to start with to collect the Sorcerer's Stone. Please help him once again.

 

Input (STDIN):

The first line contains the number of test cases T. T cases follow. Each test case consists of R C in the first line followed by the description of the grid in R lines, each containing C integers. Rows are numbered 1 to R from top to bottom and columns are numbered 1 to C from left to right. Cells with S[i][j] < 0 contain dragons, others contain magic potions.

 

Output (STDOUT):

Output T lines, one for each case containing the minimum strength Harry should start with from the cell (1,1) to have a positive strength through out his journey to the cell (R,C).

 

Constraints:

1 ≤ T ≤ 5

2 ≤ R, C ≤ 500

-10^3 ≤ S[i][j] ≤ 10^3

S[1][1] = S[R][C] = 0

 

Sample Input:

3

2 3

0 1 -3

1 -2 0

2 2

0 1

2 0

3 4

0 -2 -3 1

-1 4 0 -2

1 -2 -3 0

 

Sample Output 

2

1

2

 

Explanation:

 

Case 1 : If Harry starts with strength = 1 at cell (1,1), he cannot maintain a positive strength in any possible path. He needs at least strength = 2 initially.

Case 2 : Note that to start from (1,1) he needs at least strength = 1.

题解:

  1. 首先在任何位置剩下的体力至少为1,而且只能向下或者是向右,那么很容易想到动态规划,用m记录当前地图上将消耗或是增加的体力,然后从最后一个位置往前,每个位置计算出当前位置需要的最少的体力。最后计算到第一个位置即可。  

  2. 利用递推式  d[i][j]= max(1,min(d[i+1][j]-m[i][j],d[i][j+1]-m[i][j])); 最后面一列和最下面的一行先计算。   

     

以下是代码:

#include <cstdio>
#include <string>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <iostream>
#include <algorithm>
using namespace std;
  
#define ss(x) scanf("%d",&x)
#define ff(i,s,e) for(int i=s;i<e;i++)
#define fe(i,s,e) for(int i=s;i<=e;i++)
#define print(x) printf("%d\n",x);
#define write() freopen("1.in","r",stdin);
  
const int N =510;
int m[N][N];
int d[N][N];
int r,c;
void input(){
    ss(r);ss(c);
    fe(i,1,r)
    fe(j,1,c)
        ss(m[i][j]);
}
void dp(){
    d[r][c]=1;
    for(int i=r-1;i>=1;i--)//先计算最右边一列
        d[i][c] = max(1,d[i+1][c]-m[i][c]);
    for(int i=c-1;i>=1;i--)//先计算最下面一行
        d[r][i]= max(1,d[r][i+1]-m[r][i]);
    for(int i=r-1;i>=1;i--)
    for(int j=c-1;j>=1;j--)//遍历计算其他所有的
        d[i][j]= max(1,min(d[i+1][j]-m[i][j],d[i][j+1]-m[i][j]));
}
int main(){
    //write();
    int T;
    ss(T);
    while(T--){
        input();
        dp();
        print(d[1][1]);//输出第一个即可;
    }
}

  

 

转载于:https://www.cnblogs.com/gzdaijie/p/4316691.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值