Winter-1-C A + B II 解题报告及测试数据

Time Limit:1000MS 

Memory Limit:32768KB

Description

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input

2

1 2

112233445566778899 998877665544332211

Sample Output

Case 1:

1 + 2 = 3

 

Case 2:

112233445566778899 + 998877665544332211 = 1111111111111111110 

以下是代码:

#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
char a[1000],b[1000];
int c[1100],n;
void cal(char a[],char b[],int r)
{
    int i = strlen(a),j = strlen(b);
    int k=0,t;
    i--;j--;
    memset(c,0,sizeof(c));
    while(i>=0 || j >=0){
        if(i>=0 && j>=0)t=a[i]+b[j]+c[k]-'0'-'0';
        else if (i<0)t=b[j]+c[k]-'0';
        else t=a[i]+c[k]-'0';
        if(t>=10){
            c[k++]=t%10;c[k]+=1;
        }else c[k++]=t;
        i--;j--;
    }
    while(c[k]==0)k--;
    printf("Case %d:\n%s + %s = ",r,a,b);
    for(i=k;i>=0;i--)printf("%d",c[i]);
    printf("\n");
    if(r!=n)printf("\n");
}
int main(){
    int len1,len2;
    cin >> n;
    for(int i=0;i<n;i++){
        scanf("%s%s",a,b);
        cal(a,b,i+1);
    }
}

  

转载于:https://www.cnblogs.com/gzdaijie/p/4298088.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值