Winter-2-STL-A Argus 解题报告及测试数据

Time Limit:2000MS     Memory Limit:65536KB

Description

A data stream is a real-time, continuous, ordered sequence of items. Some examples include sensor data, Internet traffic, financial tickers, on-line auctions, and transaction logs such as Web usage logs and telephone call records. Likewise, queries over streams run continuously over a period of time and incrementally return new results as new data arrives. For example, a temperature detection system of a factory warehouse may run queries like the following.

Query-1: Every five minutes, retrieve the maximum temperature over the past five minutes. Query-2: Return the average temperature measured on each floor over the past 10 minutes.

We have developed a Data Stream Management System called Argus, which processes the queries over the data streams. Users can register queries to the Argus. Argus will keep the queries running over the changing data and return the results to the corresponding user with the desired frequency.

For the Argus, we use the following instruction to register a query:

Register Q_numPeriod

Q_num (0 < Q_num <= 3000) is query ID-number, and Period (0 < Period <= 3000) is the interval between two consecutive returns of the result. After Period seconds of register, the result will be returned for the first time, and after that, the result will be returned everyPeriod seconds.

Here we have several different queries registered in Argus at once. It is confirmed that all the queries have different Q_num. Your task is to tell the first K queries to return the results. If two or more queries are to return the results at the same time, they will return the results one by one in the ascending order of Q_num.

Input

The first part of the input are the register instructions to Argus, one instruction per line. You can assume the number of the instructions will not exceed 1000, and all these instructions are executed at the same time. This part is ended with a line of "#"

The second part is your task. This part contains only one line, which is one positive integer K (<= 10000).

Output

You should output the Q_num of the first K queries to return the results, one number per line.

Sample Input

Register 2004 200 Register 2005 300 # 5

SampleOutput

2004 2005 2004 2004 2005

 

题解:这道题其实就是一个优先队列问题,用Node.now代表应出队的时间,pe代表周期,那么无非就是以下两点:

  1. 应出队时间小的先出队。应同时出队的,ID小的先出,那么重载<运算符即可。

  2. ​每个节点出队之后再次应出队时间应加上周期,再次入队即可。            

#include <iostream>
#include <cstdio>
#include <queue>
#include <string>
using namespace std;
struct Node{
    int ID,pe,now;//pe代表周期,now代表应出队时间 
}t;
bool operator < (Node t1,Node t2){
        //优先队列,出队顺序,时间小的先出,时间一致,ID小的先出
    return t1.now>t2.now || (t1.now==t2.now && t1.ID>t2.ID);
}
int main(){
    //freopen("1.in","r",stdin);
    char str[100];
    int K;
    priority_queue<Node>q;
    while(scanf("%s",str)!=EOF && str[0]!='#'){
        scanf("%d%d",&t.ID,&t.pe);
        t.now = t.pe;
        q.push(t);
    }
    scanf("%d",&K);
    while(K--){
        t = q.top();q.pop();
        printf("%d\n",t.ID);
        t.now += t.pe;//每次出队,将now+pe后入队
        q.push(t);
    }
}

  

转载于:https://www.cnblogs.com/gzdaijie/p/4298732.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值