3143 二叉树的序遍历codevs

题目描述  Description

求一棵二叉树的前序遍历,中序遍历和后序遍历

输入描述  Input Description

第一行一个整数n,表示这棵树的节点个数。

接下来n行每行2个整数L和R。第i行的两个整数Li和Ri代表编号为i的节点的左儿子编号和右儿子编号。

输出描述  Output Description

输出一共三行,分别为前序遍历,中序遍历和后序遍历。编号之间用空格隔开。

样例输入  Sample Input

5

2 3

4 5

0 0

0 0

0 0

样例输出  Sample Output

1 2 4 5 3

4 2 5 1 3

4 5 2 3 1

数据范围及提示  Data Size & Hint

n <= 16

#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
int n;
struct node{
    int z;
    int y;
    int j;
}tree[1000];
void qian(int x)
{
    printf("%d ",tree[x].j);
    if(tree[x].z!=0)qian(tree[x].z);
    if(tree[x].y!=0)qian(tree[x].y);
}

void zhong(int x)
{
    if(tree[x].z!=0)zhong(tree[x].z);
        printf("%d ",tree[x].j);
    if(tree[x].y!=0)zhong(tree[x].y);
}

void hou(int x)
{
    if(tree[x].z!=0)hou(tree[x].z);
    if(tree[x].y!=0)hou(tree[x].y);
    printf("%d ",tree[x].j);
}
int main()
{
    cin>>n;
    for(int i=1;i<=n;i++)
    {
        cin>>tree[i].z;
        cin>>tree[i].y;
        tree[i].j=i;
    }
    qian(1);
    cout<<endl;
    zhong(1);
    cout<<endl;
    hou(1);
    cout<<endl;
    return 0;
}

 

转载于:https://www.cnblogs.com/sssy/p/6647403.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值