POJ - 1995 Raising Modulo Numbers

Raising Modulo Numbers
Time Limit:1000MS     Memory Limit:30000KB     64bit IO Format:%lld & %llu

Description

People are different. Some secretly read magazines full of interesting girls' pictures, others create an A-bomb in their cellar, others like using Windows, and some like difficult mathematical games. Latest marketing research shows, that this market segment was so far underestimated and that there is lack of such games. This kind of game was thus included into the KOKODáKH. The rules follow: 

Each player chooses two numbers Ai and Bi and writes them on a slip of paper. Others cannot see the numbers. In a given moment all players show their numbers to the others. The goal is to determine the sum of all expressions Ai  Bi from all players including oneself and determine the remainder after division by a given number M. The winner is the one who first determines the correct result. According to the players' experience it is possible to increase the difficulty by choosing higher numbers. 

You should write a program that calculates the result and is able to find out who won the game. 

Input

The input consists of Z assignments. The number of them is given by the single positive integer Z appearing on the first line of input. Then the assignements follow. Each assignement begins with line containing an integer M (1 <= M <= 45000). The sum will be divided by this number. Next line contains number of players H (1 <= H <= 45000). Next exactly H lines follow. On each line, there are exactly two numbers Ai and Bi separated by space. Both numbers cannot be equal zero at the same time.

Output

For each assingnement there is the only one line of output. On this line, there is a number, the result of expression 

(A1B1+A2B2+ ... +AHBH)mod M.

Sample Input

3
16
4
2 3
3 4
4 5
5 6
36123
1
2374859 3029382
17
1
3 18132

Sample Output

2
13195
13
这道题题目真长。。抓狂还难理解,读了大半天,愣是没搞懂。。好吧,让我试着来翻译一下 安静 先输入一个数t,代表t组测试样例;接下来每个样例中有一个数M,下一行H,接下来H行是选手所拿的纸片上的数字Ai,Bi(可以定义两个数组),而你需要计算出各个Ai^Bi相加后的和再对M取余的值。
#include<cstdio>
long long pow(long long a,long long p,long long m){
	long long ans=1,base=a;
	while(p){
		if(p&1)
			ans=(base*ans)%m;
		base=(base*base)%m;
		p>>=1;
	}
	return ans;
}//快速幂求模 
int main(){
	long long z,sum;
	int m,n,a[50001],b[50001];//数组a,b分别存放Ai,Bi 
	scanf("%d",&z);
	while(z--){
		sum=0;
		scanf("%d%d",&m,&n);
		for(int i=0;i<n;i++)
			scanf("%d %d",&a[i],&b[i]);
		for(int i=0;i<n;i++)
			sum=(sum+pow(a[i],b[i],m))%m;//边求和边取余,防止数据超限 
		printf("%lld\n",sum);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值