约瑟夫问题

约瑟夫问题

Time Limit: 1000 ms Memory Limit: 65536 KiB
Problem Description
n个人想玩残酷的死亡游戏,游戏规则如下:

n个人进行编号,分别从1到n,排成一个圈,顺时针从1开始数到m,数到m的人被杀,剩下的人继续游戏,活到最后的一个人是胜利者。

请输出最后一个人的编号。
Input
输入n和m值。
Output
输出胜利者的编号。
Sample Input
5 3
Sample Output
4
Hint
第一轮:3被杀第二轮:1被杀第三轮:5被杀第四轮:2被杀

Source

解法:要注意变量的a,b的使用意义。


#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
using namespace std;
struct node{
	int data;
	struct node *next;
};
int main(){
	int i,n,m,a=0,b=0;
	cin>>n>>m;
	struct node *head,*p,*tail,*q;
	p=(struct node *)malloc(sizeof(struct node));
	p->data=1;
	p->next=NULL;
	head=p;
	tail=p;
	for(i=2;i<=n;i++){
		p=(struct node *)malloc(sizeof(struct node));
		p->data=i;
		p->next=NULL;
		tail->next=p;
		tail=p;	
	}
	tail->next=head;
	
	p=head->next;
	while(p->next!=head){
		p=p->next;
	}
	q=p->next;
	while(a<n-1){
		q=p->next;
		b++;
		if(b%m==0){
			p->next=q->next;
			free(q);
			a++;
		}else{
			p=q;
		}
	}
	printf("%d",p->data);
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值