C - How Many Nines

If we represent a date in the format YYYY-MM-DD (for example, 2017-04-09), do you know how many 9s will appear in all the dates between Y1-M1-D1 and Y2-M2-D2 (both inclusive)?

Note that you should take leap years into consideration. A leap year is a year which can be divided by 400 or can be divided by 4 but can't be divided by 100.

Input

The first line of the input is an integer T (1 ≤ T ≤ 105), indicating the number of test cases. Then T test cases follow. For each test case:

The first and only line contains six integers Y1M1D1Y2M2D2, their meanings are described above.

It's guaranteed that Y1-M1-D1 is not larger than Y2-M2-D2. Both Y1-M1-D1 and Y2-M2-D2 are between 2000-01-01 and 9999-12-31, and both dates are valid.

We kindly remind you that this problem contains large I/O file, so it's recommended to use a faster I/O method. For example, you can use scanf/printf instead of cin/cout in C++.

Output

For each test case, you should output one line containing one integer, indicating the answer of this test case.

Sample Input
4
2017 04 09 2017 05 09
2100 02 01 2100 03 01
9996 02 01 9996 03 01
2000 01 01 9999 12 31
Sample Output
4
2
93
1763534
Hint

For the first test case, four 9s appear in all the dates between 2017-04-09 and 2017-05-09. They are: 2017-04-09 (one 9), 2017-04-19 (one 9), 2017-04-29 (one 9), and 2017-05-09 (one 9).

For the second test case, as year 2100 is not a leap year, only two 9s appear in all the dates between 2100-02-01 and 2100-03-01. They are: 2017-02-09 (one 9) and 2017-02-19 (one 9).

For the third test case, at least three 9s appear in each date between 9996-02-01 and 9996-03-01. Also, there are three additional nines, namely 9996-02-09 (one 9), 9996-02-19 (one 9) and 9996-02-29 (one 9). So the answer is 3 × 30 + 3 = 93.



假如:时间sum1 到 sum2的9的个数。

思路,

  对于时间多的,(1)你可以写出来sum1中,sum1 - 01 - 01 到现在的sum1的9的个数。

                              (2)写出来sum2中,sum2 - 01 - 01 到现在的sum2的9的个数。

                              (3)写出年的相差中的9个个数,再去处理就可以了。

  对于时间少的,你可以去预处理。题目给出了时间间隔:2000-01-01 and 9999-12-31。

第一种方法坑点:(1)注意:9月是30*1+3个,

                                (2)年中含9。

第二种方法坑点:(1)年中含9。


其余的就没有了。最好是预处理,因为时间不够,这题,只有一秒。

超时代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>

using namespace std;
typedef long long ll;

int n1,y1,r1,n2,y2,r2;

int v1[] = {0,31,28,31,30,31,30,31,31,30,31,30,31};
int v[]= {0,3,3,3,3,3,3,3,3,33,3,3,3};

int cmp(int n)
{
    int k=0;
    while(n)
    {
        int t = n%10;
        if(t==9) k++;
        n=n/10;
    }
    return k;
}


///相差的年的数目
ll cha()
{
    int k1 = 0;
    for(int i=n1; i<n2; i++)
    {
        if(i%4==0 && i%100!=0 || i%400==0)
            k1+=11*3+33+cmp(i)*366;
        else
            k1+=10*3+2+33+cmp(i)*365;
    }
    return k1;
}

///该年01-01到先在的9的个数
ll qian(int n1,int y1,int r1,int t)
{
    int k=0;
    if(n1%4==0 && n1%100!=0 || n1%400==0)
    {
        v[2] = 3;
        v1[2]=29;
    }
    else
    {
        v[2] = 2;
        v1[2]=28;
    }
    int rq1 =0;
    for(int i =1; i<y1 ; i++)
    {
        k+=v[i];
        rq1+=v1[i];
    }
    if(t==1)
    {
      r1-=1;
    }
    rq1 += r1;
    k += rq1*cmp(n1);
    if(r1%10==9)
        k =k + r1/10+1;
    else
        k =k + (r1/10);
    return k;
}

int main()
{
    int n;
    scanf("%d",&n);
    while(n--)
    {
        scanf("%d%d%d%d%d%d",&n1,&y1,&r1,&n2,&y2,&r2);
        printf("%lld\n",cha()-qian(n1,y1,r1,1)+qian(n2,y2,r2,0));
    }
    return 0;
}


01 到 31中一个数r1中含9的个数:r1/10+r1%10==9?1:0;你可以用29,31代入看看。

预处理的代码:
 

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>


using namespace std;
typedef long long ll;
///思路存储。
///把每一个都存起来。
int ans[10000][13][32];
int vis[]={0,31,28,31,30,31,30,31,31,30,31,30,31};

///每一个数的9的个数
int mei(int n)
{
    int k=0;
    while(n)
    {
        int t = n%10;
        n=n/10;
        if(t==9) k++;
    }
    return k;
}

void cmp()
{
    ///x表示年 y表示月 z表示日
    int x=2000,y=1,z=1;
    ll sum =0;
    while(!(x==10000 && y==1 && z==1))
    {
        if(x%4==0 && x%100!=0 || x%400==0)
            vis[2] = 29;
        else
            vis[2] = 28;
        sum+=mei(x)+mei(y)+mei(z);
        ans[x][y][z] = sum;
        z++;
        if(z>vis[y])
        {
            y++;
            z=1;
            if(y>12)
            {
                y=1;
                x++;
            }
        }
    }
}

int main()
{
    memset(ans,0,sizeof(ans));
    ///预处理
    cmp();
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int n1,n2,y1,y2,r1,r2;
        scanf("%d%d%d%d%d%d",&n1,&y1,&r1,&n2,&y2,&r2);
        printf("%d\n",ans[n2][y2][r2]-ans[n1][y1][r1]+ mei(n1)+ mei(y1) + mei(r1));
    }
    return 0;
}

转载于:https://www.cnblogs.com/new-zjw/p/8540975.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值