How Many Nines

If we represent a date in the format YYYY-MM-DD (for example, 2017-04-09), do you know how many 9s will appear in all the dates between Y1-M1-D1 and Y2-M2-D2 (both inclusive)?

Note that you should take leap years into consideration. A leap year is a year which can be divided by 400 or can be divided by 4 but can't be divided by 100.

Input
The first line of the input is an integer T (1 ≤ T ≤ 105), indicating the number of test cases. Then T test cases follow. For each test case:

The first and only line contains six integers Y1, M1, D1, Y2, M2, D2, their meanings are described above.

It's guaranteed that Y1-M1-D1 is not larger than Y2-M2-D2. Both Y1-M1-D1 and Y2-M2-D2 are between 2000-01-01 and 9999-12-31, and both dates are valid.

We kindly remind you that this problem contains large I/O file, so it's recommended to use a faster I/O method. For example, you can use scanf/printf instead of cin/cout in C++.

Output
For each test case, you should output one line containing one integer, indicating the answer of this test case.

Sample Input
4
2017 04 09 2017 05 09
2100 02 01 2100 03 01
9996 02 01 9996 03 01
2000 01 01 9999 12 31
Sample Output
4
2
93
1763534
Hint
For the first test case, four 9s appear in all the dates between 2017-04-09 and 2017-05-09. They are: 2017-04-09 (one 9), 2017-04-19 (one 9), 2017-04-29 (one 9), and 2017-05-09 (one 9).

For the second test case, as year 2100 is not a leap year, only two 9s appear in all the dates between 2100-02-01 and 2100-03-01. They are: 2017-02-09 (one 9) and 2017-02-19 (one 9).

For the third test case, at least three 9s appear in each date between 9996-02-01 and 9996-03-01. Also, there are three additional nines, namely 9996-02-09 (one 9), 9996-02-19 (one 9) and 9996-02-29 (one 9). So the answer is 3 × 30 + 3 = 93.


思路:从2000到10000年每一天有9的都存到数组里面 ,正好对应三维数组。


#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
using namespace std;
int ans[10000][13][32];
int mou[13]={0,31,28,31,30,31,30,31,31,30,31,30,31};
int work(int n)
{
    int sum=0;
    while(n)
    {
        if(n%10==9)
            sum++;
        n=n/10;
    }
    return sum;
}
int budge(int n)
{
    if((n%4==0&&n%100!=0)||(n%400==0))
        return 1;
    else
        return 0;
}
int main()
{
    int n,m,b,c,d,a[6];
    long long sum=0;
    b=2000;c=1,d=1;
    while(!(b==10000&&c==1&&d==1))//b为年,c为月,d为日;
    {
        mou[2]=28+budge(b);
        sum+=work(b)+work(c)+work(d);
        ans[b][c][d]=sum;
        d++;
        if(d>mou[c])
        {
            c++;
            d=1;
            if(c>12)
            {
                c=1;
                b++;
            }
        }
    }
    //printf("%d %d\n",ans[2000][2][9],ans[2000][1][9]);
    scanf("%d",&m);
    int i;
    while(m--)
    {
        for(i=0;i<6;i++)
        {
            scanf("%d",&a[i]);
        }
        printf("%d\n",ans[a[3]][a[4]][a[5]]-ans[a[0]][a[1]][a[2]]+work(a[0])+work(a[1])+work(a[2]));
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值