zoj3950——How Many Nines(日期模拟)

If we represent a date in the format YYYY-MM-DD (for example, 2017-04-09), do you know how many 9s will appear in all the dates between Y1-M1-D1 and Y2-M2-D2 (both inclusive)?

Note that you should take leap years into consideration. A leap year is a year which can be divided by 400 or can be divided by 4 but can’t be divided by 100.

Input

The first line of the input is an integer T (1 ≤ T ≤ 105), indicating the number of test cases. Then T test cases follow. For each test case:

The first and only line contains six integers Y1, M1, D1, Y2, M2, D2, their meanings are described above.

It’s guaranteed that Y1-M1-D1 is not larger than Y2-M2-D2. Both Y1-M1-D1 and Y2-M2-D2 are between 2000-01-01 and 9999-12-31, and both dates are valid.

We kindly remind you that this problem contains large I/O file, so it’s recommended to use a faster I/O method. For example, you can use scanf/printf instead of cin/cout in C++.

Output

For each test case, you should output one line containing one integer, indicating the answer of this test case.

Sample Input

4
2017 04 09 2017 05 09
2100 02 01 2100 03 01
9996 02 01 9996 03 01
2000 01 01 9999 12 31
Sample Output

4
2
93
1763534
Hint

For the first test case, four 9s appear in all the dates between 2017-04-09 and 2017-05-09. They are: 2017-04-09 (one 9), 2017-04-19 (one 9), 2017-04-29 (one 9), and 2017-05-09 (one 9).

For the second test case, as year 2100 is not a leap year, only two 9s appear in all the dates between 2100-02-01 and 2100-03-01. They are: 2017-02-09 (one 9) and 2017-02-19 (one 9).

For the third test case, at least three 9s appear in each date between 9996-02-01 and 9996-03-01. Also, there are three additional nines, namely 9996-02-09 (one 9), 9996-02-19 (one 9) and 9996-02-29 (one 9). So the answer is 3 × 30 + 3 = 93.

求输入的两个时间段内有多少个9
先每年打表,接下来只要判断端点,时间会大大减少

#include <iostream>
#include <cstring>
#include <string>
#include <vector>
#include <queue>
#include <cstdio>
#include <set>
#include <math.h>
#include <algorithm>
#include <queue>
#include <iomanip>
#include <map>
#define INF 0x3f3f3f3f
#define MAXN 1005
#define Mod 99999999
using namespace std;
int num[10005];
int count9(int n)
{
    int cnt=0;
    while(n!=0)
    {
        if(n%10==9)
            cnt++;
        n/=10;
    }
    return cnt;
}
bool isleap(int y)
{
    if((y%4==0&&y%100!=0)||y%400==0)
        return true;
    return false;
}
void Init()
{
    int sum=0;
    for(int i=2000; i<=9999; ++i)
    {
        if(isleap(i))
            sum=count9(i)*366;
        else
            sum=count9(i)*365;
        sum+=30;
        sum+=11*3;
        if(isleap(i))
            sum+=3;
        else
            sum+=2;
        num[i]=sum;
    }
}
int mon1[]= {0,31,28,31,30,31,30,31,31,30,31,30,31};
int mon2[]= {0,31,29,31,30,31,30,31,31,30,31,30,31};
int main()
{
    Init();
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int y1,m1,d1,y2,m2,d2;
        int ans=0;
        scanf("%d%d%d%d%d%d",&y1,&m1,&d1,&y2,&m2,&d2);
        if(y1==y2)
        {
            int days=0;
            for(int i=m1+1; i<m2; ++i)
            {
                if(i==2&&isleap(y1))
                    ans+=3;
                else if(i==2&&!isleap(y1))
                    ans+=2;
                else if(i==9)
                    ans+=33;
                else
                    ans+=3;
                if(!isleap(y1))
                    days+=mon1[i];
                else
                    days+=mon2[i];
            }
            if(m1==m2)
            {
                for(int i=d1; i<=d2; ++i)
                {
                    ans+=count9(i);
                    days++;
                    if(m1==9)
                        ans++;
                }
                ans=ans+days*count9(y1);
                printf("%d\n",ans);
            }
            else
            {
                if(!isleap(y1))
                {
                    for(int i=d1; i<=mon1[m1]; ++i)
                    {
                        ans+=count9(i);
                        days++;
                        if(m1==9)
                            ans++;
                    }
                }
                else
                {
                    for(int i=d1; i<=mon2[m1]; ++i)
                    {
                        ans+=count9(i);
                        days++;
                        if(m1==9)
                            ans++;
                    }
                }
                for(int i=1; i<=d2; ++i)
                {
                    ans+=count9(i);
                    days++;
                    if(m2==9)
                        ans++;
                }
                ans=ans+days*count9(y1);
                printf("%d\n",ans);
            }
        }
        else
        {
            for(int i=y1+1; i<y2; ++i)
                ans+=num[i];
            int days1=0,days2=0;
            for(int i=m1+1; i<=12; ++i)
            {
                if(i==2&&isleap(y1))
                    ans+=3;
                else if(i==2&&!isleap(y1))
                    ans+=2;
                else if(i==9)
                    ans+=33;
                else
                    ans+=3;
                if(!isleap(y1))
                    days1+=mon1[i];
                else
                    days1+=mon2[i];
            }
            if(!isleap(y1))
            {
                for(int i=d1; i<=mon1[m1]; ++i)
                {
                    ans+=count9(i);
                    days1++;
                    if(m1==9)
                        ans++;
                }
            }
            else
            {
                for(int i=d1; i<=mon2[m1]; ++i)
                {
                    ans+=count9(i);
                    days1++;
                    if(m1==9)
                        ans++;
                }
            }
            ans=ans+days1*count9(y1);

            for(int i=1; i<m2; ++i)
            {
                if(i==2&&isleap(y2))
                    ans+=3;
                else if(i==2&&!isleap(y2))
                    ans+=2;
                else if(i==9)
                    ans+=33;
                else
                    ans+=3;
                if(!isleap(y2))
                    days2+=mon1[i];
                else
                    days2+=mon2[i];
            }
            for(int i=1; i<=d2; ++i)
            {
                ans+=count9(i);
                days2++;
                if(m2==9)
                    ans++;
            }
            ans=ans+days2*count9(y2);
            printf("%d\n",ans);
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 5
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 5
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值