HDOJ Assign the task

 

Assign the task

Time Limit : 15000/5000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 4   Accepted Submission(s) : 2
Font: Times New Roman | Verdana | Georgia
Font Size: ← →

Problem Description

There is a company that has N employees(numbered from 1 to N),every employee in the company has a immediate boss (except for the leader of whole company).If you are the immediate boss of someone,that person is your subordinate, and all his subordinates are your subordinates as well. If you are nobody's boss, then you have no subordinates,the employee who has no immediate boss is the leader of whole company.So it means the N employees form a tree.

The company usually assigns some tasks to some employees to finish.When a task is assigned to someone,He/She will assigned it to all his/her subordinates.In other words,the person and all his/her subordinates received a task in the same time. Furthermore,whenever a employee received a task,he/she will stop the current task(if he/she has) and start the new one.

Write a program that will help in figuring out some employee’s current task after the company assign some tasks to some employee.

Input

The first line contains a single positive integer T( T <= 10 ), indicates the number of test cases.

For each test case:

The first line contains an integer N (N ≤ 50,000) , which is the number of the employees.

The following N - 1 lines each contain two integers u and v, which means the employee v is the immediate boss of employee u(1<=u,v<=N).

The next line contains an integer M (M ≤ 50,000).

The following M lines each contain a message which is either

"C x" which means an inquiry for the current task of employee x

or

"T x y"which means the company assign task y to employee x.

(1<=x<=N,0<=y<=10^9)

Output

For each test case, print the test case number (beginning with 1) in the first line and then for every inquiry, output the correspond answer per line.

Sample Input

1 
5 
4 3 
3 2 
1 3 
5 2 
5 
C 3 
T 2 1
 C 3 
T 3 2 
C 3

Sample Output

Case #1:
-1 
1 
2

Source

2011 Multi-University Training Contest 14 - Host by FZU
 
这题不用线段树还好解决一点。
//每个结点最多有一个父结点
//查找的时候只需查找最近更新的上司(这里要查遍某个节点所有的上司,找出谁是最近更新的)
#include<iostream>
#include<cstring>
using namespace std;
const int maxn=50005;
struct node{
       int time,key;  //设置一个time来判断是否是最近更新的数据
}node[maxn];
int parent[maxn];
int main(){
    int t,cnt,n,m,u,v;
    char str[5];
    scanf("%d",&t);
    for(cnt=1;cnt<=t;cnt++){
         memset(parent,-1,sizeof(parent));
         scanf("%d",&n);
         for(int i=1;i<=n-1;i++){
             scanf("%d%d",&u,&v);
             parent[u]=v;
         }   
         for(int i=1;i<=n;i++){
              node[i].time=-1;
              node[i].key=-1;
         }
         scanf("%d",&m);
         printf("Case #%d:\n",cnt);
         int x,k,T=0;
         while(m--){                 
                scanf("%s",str);
                if(str[0]=='T'){
                     scanf("%d%d",&x,&k);
                     node[x].key=k;
                     node[x].time=++T; //注意这一步                       
                }
                else{
                     scanf("%d",&x);
                     k=node[x].key;
                     int time=node[x].time;
                     while(x!=-1){   //查找最近更新的上司
                          if(node[x].time>time){
                               k=node[x].key;
                               time=node[x].time;                
                          }
                          x=parent[x];                   
                     }
                     printf("%d\n",k);  
                }                        
         }                      
    } 
    //system("pause");
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值