F - Assign the task

There is a company that has N employees(numbered from 1 to N),every employee in the company has a immediate boss (except for the leader of whole company).If you are the immediate boss of someone,that person is your subordinate, and all his subordinates are your subordinates as well. If you are nobody's boss, then you have no subordinates,the employee who has no immediate boss is the leader of whole company.So it means the N employees form a tree. 

The company usually assigns some tasks to some employees to finish.When a task is assigned to someone,He/She will assigned it to all his/her subordinates.In other words,the person and all his/her subordinates received a task in the same time. Furthermore,whenever a employee received a task,he/she will stop the current task(if he/she has) and start the new one. 

Write a program that will help in figuring out some employee’s current task after the company assign some tasks to some employee.
InputThe first line contains a single positive integer T( T <= 10 ), indicates the number of test cases. 

For each test case: 

The first line contains an integer N (N ≤ 50,000) , which is the number of the employees. 

The following N - 1 lines each contain two integers u and v, which means the employee v is the immediate boss of employee u(1<=u,v<=N). 

The next line contains an integer M (M ≤ 50,000). 

The following M lines each contain a message which is either 

"C x" which means an inquiry for the current task of employee x 

or 

"T x y"which means the company assign task y to employee x. 

(1<=x<=N,0<=y<=10^9)OutputFor each test case, print the test case number (beginning with 1) in the first line and then for every inquiry, output the correspond answer per line.Sample Input
1 
5 
4 3 
3 2 
1 3 
5 2 
5 
C 3 
T 2 1
 C 3 
T 3 2 
C 3
Sample Output
Case #1:
-1 
1 

2

并查集!

先确定每个人的老板关系!在结构体中增加一个time,表示被分配任务的时间!最后查找的时候,都是查找到company的老板,查找途中,遇到更新time迟的就更新ans!可以保证最后答案一定是最后布置的!

#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <cctype>
#include <iostream>
#include <algorithm>
#include <string>
#include <vector>
#include <queue>
#include <map>
#include <set>
#include <sstream>
#include<iomanip>
using namespace std;
typedef long long ll;
#define inf int(0x3f3f3f3f)
#define mod int(1e9+7)
#define pi acos(-1)
#define N 50005

struct
{
	int task;
	int time;
}  po[N];


int t,n,u,v,x,y,m;
int pre[N];
int main()
{
	scanf("%d",&t);
	int casee=1;
	while(t--)
	{
		scanf("%d",&n);
		for(int i=1;i<=n;i++)
		{
			po[i].task=-1;
			po[i].time=0;
		}
		for(int i=1;i<=n;i++)
		  pre[i]=i;
		for(int i=1;i<=n-1;i++)
		{
			scanf("%d%d",&u,&v);
			pre[u]=v;
		}
		scanf("%d",&m);
		char s[5];
		int t=1;
		printf("Case #%d:\n",casee++);
		while(m--)
		{
			int time=0;
			int ans=-1;
			scanf("%s",s);
			if(s[0]=='C')
			{
				scanf("%d",&x);
				while(pre[x]!=x)
				{
					if(po[x].time>time)
					{
						time=po[x].time;
						ans=po[x].task;
					}
					x=pre[x];
				}
				if(po[x].time>time) ans=po[x].task;
				printf("%d\n",ans);
			}
			else
			{
				scanf("%d%d",&x,&y);
				po[x].task=y;
				po[x].time=t++;
			}
		}
	}
	return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值