Robot Motion

Q - Robot Motion
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description



A robot has been programmed to follow the instructions in its path. Instructions for the next direction the robot is to move are laid down in a grid. The possible instructions are 

N north (up the page)
S south (down the page)
E east (to the right on the page)
W west (to the left on the page)

For example, suppose the robot starts on the north (top) side of Grid 1 and starts south (down). The path the robot follows is shown. The robot goes through 10 instructions in the grid before leaving the grid.

Compare what happens in Grid 2: the robot goes through 3 instructions only once, and then starts a loop through 8 instructions, and never exits.

You are to write a program that determines how long it takes a robot to get out of the grid or how the robot loops around.
 

Input

There will be one or more grids for robots to navigate. The data for each is in the following form. On the first line are three integers separated by blanks: the number of rows in the grid, the number of columns in the grid, and the number of the column in which the robot enters from the north. The possible entry columns are numbered starting with one at the left. Then come the rows of the direction instructions. Each grid will have at least one and at most 10 rows and columns of instructions. The lines of instructions contain only the characters N, S, E, or W with no blanks. The end of input is indicated by a row containing 0 0 0.
 

Output

For each grid in the input there is one line of output. Either the robot follows a certain number of instructions and exits the grid on any one the four sides or else the robot follows the instructions on a certain number of locations once, and then the instructions on some number of locations repeatedly. The sample input below corresponds to the two grids above and illustrates the two forms of output. The word "step" is always immediately followed by "(s)" whether or not the number before it is 1.
 

Sample Input

       
       
3 6 5 NEESWE WWWESS SNWWWW 4 5 1 SESWE EESNW NWEEN EWSEN 0 0
 

Sample Output

       
       
10 step(s) to exit 3 step(s) before a loop of 8 step(s)
 
#include<iostream>
#include<cstring>
using namespace std;
char map[15][15];
int visited[15][15];//visited[i][j]记录第几步时走过点map[i][j] 
int row,col,entry;
bool escape;
int count1,count2;
void dfs(int r,int c,int cnt){
     if(r<1 || c<1 || r>row || c>col){
          escape=true; 
          count1=cnt;
          return ;
     }
     if(visited[r][c]){//为真,那么它的值表示在第几步走过这点 
          escape=false;
          count1=visited[r][c];
          count2=cnt-visited[r][c];
          return ;
     }
     visited[r][c]=cnt;
     
     if(map[r][c]=='W')
          dfs(r,c-1,cnt+1);         
     else if(map[r][c]=='S')
          dfs(r+1,c,cnt+1);
     else if(map[r][c]=='E')
          dfs(r,c+1,cnt+1);
     else if(map[r][c]=='N')
          dfs(r-1,c,cnt+1); 


}
int main(){
    while(cin>>row>>col){
         if(row==0 && col==0) 
             break;
         cin>>entry;
         for(int i=1;i<=row;i++)
            for(int j=1;j<=col;j++)
               cin>>map[i][j];  
         memset(visited,0,sizeof(visited));                        
         escape=false;
         count1=count2=0;
         dfs(1,entry,1); //数据有点恶心,第三个参数必须为1,然后下面再减1
         if(escape)
              cout<<count1-1<<" step(s) to exit"<<endl;
         else 
              cout<<count1-1<<" step(s) before a loop of "<<count2<<" step(s)"<<endl;         
                       
    }


//system("pause");
return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值