COURSES - 北电1469 (二分匹配)

本文深入探讨了一种课程匹配算法,该算法旨在从N名学生中为P门课程找到恰好P名学生的委员会,确保每名学生代表不同的课程,且每门课程都有代表。通过输入数据集,包括学生和课程的数量及学生选课情况,算法使用匈牙利算法变体来判断是否可以形成这样的委员会。文章提供了详细的算法实现代码,并附有示例输入输出。
摘要由CSDN通过智能技术生成

Description

Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is possible to form a committee of exactly P students that satisfies simultaneously the conditions:  

  • every student in the committee represents a different course (a student can represent a course if he/she visits that course) 
  • each course has a representative in the committee 

Input

Your program should read sets of data from the std input. The first line of the input contains the number of the data sets. Each data set is presented in the following format:  

P N  
Count1 Student 1 1  Student 1 2  ... Student 1 Count1  
Count2 Student 2 1  Student 2 2  ... Student 2 Count2  
...  
CountP Student P 1  Student P 2  ... Student P CountP  

The first line in each data set contains two positive integers separated by one blank: P (1 <= P <= 100) - the number of courses and N (1 <= N <= 300) - the number of students. The next P lines describe in sequence of the courses �from course 1 to course P, each line describing a course. The description of course i is a line that starts with an integer Count i (0 <= Count i <= N) representing the number of students visiting course i. Next, after a blank, you抣l find the Count i students, visiting the course, each two consecutive separated by one blank. Students are numbered with the positive integers from 1 to N.  
There are no blank lines between consecutive sets of data. Input data are correct.  

Output

The result of the program is on the standard output. For each input data set the program prints on a single line "YES" if it is possible to form a committee and "NO" otherwise. There should not be any leading blanks at the start of the line.

Sample Input

2
3 3
3 1 2 3
2 1 2
1 1
3 3
2 1 3
2 1 3
1 1

Sample Output

YES
NO
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#define N 350
int courses;
int students;
bool state[N][N];
int pai[N];
bool color[N];
bool fine(int k){
	int i;
	bool t;
	for(i=1;i<=students;i++){
		if(state[k][i]&&!color[i]){
			color[i]=true;
			if(!pai[i]||fine(pai[i])){
				pai[i]=k;
				return true;
			}
		}
	}
	return false;
}
int main(){
	int i,n,p,V,j,m,k;
	freopen("in.txt","r",stdin);
	freopen("out.txt","w",stdout);
	scanf("%d",&m);
	for(k=0;k<m;k++){
		scanf("%d%d",&courses,&students);
		memset(state,false,sizeof(state));
		for(i=1;i<=courses;i++){
			scanf("%d",&n);
			for(j=0;j<n;j++){
				scanf("%d",&p);
				state[i][p]=true;
			}
		}
		V=0;
		memset(pai,0,sizeof(pai));
		for(i=1;i<=courses;i++){
			memset(color,false,sizeof(color));
			if(fine(i))
				V++;
		}
		if(V==courses)//当匹配数等于科目数,即每个科目都找到了同学加入委员会,输出YES
			printf("YES\n");
		else 
			printf("NO\n");
	}	
	return 0;
}

  

转载于:https://www.cnblogs.com/kahreman/archive/2011/08/10/2133795.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值