poj 1716 Integer Intervals

Description

An integer interval [a,b], a < b, is a set of all consecutive integers beginning with a and ending with b. 
Write a program that: finds the minimal number of elements in a set containing at least two different integers from each interval.

Input

The first line of the input contains the number of intervals n, 1 <= n <= 10000. Each of the following n lines contains two integers a, b separated by a single space, 0 <= a < b <= 10000. They are the beginning and the end of an interval.

Output

Output the minimal number of elements in a set containing at least two different integers from each interval.

Sample Input

4
3 6
2 4
0 2
4 7

Sample Output

4

以前做的是选一个点,这个题是选两个点,不过做法都一样,都是选区间最后两个点
#include<iostream>
#include<cstdio>
#include<map>
#include<cstring>
#include<string>
#include<algorithm>
#include<cmath>
#include<vector>
#include<set>

using namespace std;
const int maxn=10000+10;

struct node
{
          int x,y;
}a[maxn];
bool vis[maxn];

bool cmp(node xx,node yy)
{
          return xx.y<yy.y;
}

int main()
{
          int n;
          while(scanf("%d",&n)!=EOF)
          {
                    for (int i=1;i<=n;i++) scanf("%d%d",&a[i].x,&a[i].y);
                    sort(a+1,a+n+1,cmp);
                    memset(vis,0,sizeof(vis));
                    vis[a[1].y]=1;
                    vis[a[1].y-1]=1;
                    int ans=2;
                    for (int i=2;i<=n;i++)
                    {
                              int m=0;
                              for (int j=a[i].x;j<=a[i].y;j++)
                              {
                                        if (vis[j]) m++;
                                        if (m==2) break;
                              }
                              if (m==0)
                              {
                                        vis[a[i].y]=1;
                                        vis[a[i].y-1]=1;
                                        ans+=2;
                              }
                              if (m==1)
                              {
                                        vis[a[i].y]=1;
                                        ans++;
                              }
                    }
                    printf("%d\n",ans);
          }
          return 0;
}

 

转载于:https://www.cnblogs.com/chensunrise/p/3791078.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值