Little Valentine liked playing with binary trees very much. Her favorite game was constructing randomly looking binary trees with capital letters in the nodes.
This is an example of one of her creations:
D / \ / \ B E / \ \ / \ \ A C G / / F
To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree). For the tree drawn above the preorder traversal is DBACEGF and the inorder traversal is ABCDEFG.
She thought that such a pair of strings would give enough information to reconstruct the tree later (but she never tried it).
Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree.
However, doing the reconstruction by hand, soon turned out to be tedious.
So now she asks you to write a program that does the job for her!
Input
The input will contain one or more test cases.
Each test case consists of one line containing two strings preord and inord, representing the preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters. (Thus they are not longer than 26 characters.)
Input is terminated by end of file.
Output
For each test case, recover Valentine's binary tree and print one line containing the tree's postorder traversal (left subtree, right subtree, root).
Sample Input
DBACEGF ABCDEFG BCAD CBAD
Sample Output
ACBFGED CDAB
题意:给你一棵树的前序遍历和中序遍历,让你求后序遍历。利用递归的思想,找到他的根节点,然后在找到左子树和右子树,然后遍历输出就行。
#include<stdio.h>
#include<string.h>
char l[1010],r[1010];
void cn(int x,char l[],char r[])
{
if(x<=0)
return ;
int w=strchr(r,l[0])-r;
cn(w,l+1,r);
cn(x-w-1,l+w+1,r+w+1);
printf("%c",l[0]);
}
int main()
{
while(~scanf("%s %s",l,r))
{
getchar();
int len=strlen(l);
cn(len,l,r);
printf("\n");
}
return 0;
}