A Strange Tree (S-tree) over the variable set Xn = {x1,x2,...,xn} is a binary tree representing a Boolean function f : {0,1}n → {0,1}. Each path of the S-tree begins at the root node and consists of n + 1 nodes. Each of the S-tree’s nodes has a depth, which is the amount of nodes between itself and the root (so the root has depth 0). The nodes with depth less than n are called non-terminal nodes. All non-terminal nodes have two children: the right child and the left child. Each non-terminal node is marked with some variable xi from the variable set Xn. All non-terminal nodes with the same deptharemarkedwiththesamevariable, andnon-terminalnodeswithdifferentdeptharemarkedwith different variables. So, there is a unique variable xi1 corresponding to the root, a unique variable xi2 corresponding to the nodes with depth 1, and so on. The sequence of the variables xi1, xi2, ..., xin is called the variable ordering. The nodes having depth n are called terminal nodes. They have no children and are marked with either 0 or 1. Note that the variable ordering and the distribution of 0’s and 1’s on terminal nodes are sufficient to completely describe an S-tree. As stated earlier, each S-tree represents a Boolean function f. If you have an S-tree and values for the variables x1, x2, ..., xn, then it is quite simple to find out what f(x1,x2,...,xn) is: start with the root. Now repeat the following: if the node you are at is labelled with a variable xi, then depending on whether the value of the variable is 1 or 0, you go its right or left child, respectively. Once you reach a terminal node, its label gives the value of the function.
Figure 1: S-trees for the function x1 ∧(x2 ∨x3) On the picture, two S-trees representing the same Boolean function, f(x1,x2,x3) = x1 ∧(x2 ∨x3), are shown. For the left tree, the variable ordering is x1,x2,x3, and for the right tree it is x3,x1,x2. The values of the variables x1, x2, ..., xn, are given as a Variable Values Assignment (VVA)
(x1 = b1,x2 = b2,...,xn = bn) with b1,b2,...,bn ∈ {0,1}. For instance, (x1 = 1, x2 = 1, x3 = 0) would be a valid VVA for n = 3, resulting for the sample function above in the value f(1,1,0) = 1∧(1∨0) = 1. The corresponding paths are shown bold in the picture. YourtaskistowriteaprogramwhichtakesanS-treeandsomeVVAsandcomputesf(x1,x2,...,xn) as described above.
Input The input file contains the description of several S-trees with associated VVAs which you have to process. Each description begins with a line containing a single integer n, 1 ≤ n ≤ 7, the depth of the S-tree. This is followed by a line describing the variable ordering of the S-tree. The format of that line is xi1 xi2 ... xin. (There will be exactly n different space-separated strings). So, for n = 3 and the variable ordering x3, x1, x2, this line would look as follows: x3 x1 x2 Inthenextlinethedistributionof0’sand1’sovertheterminalnodesisgiven. Therewillbeexactly 2n characters (each of which can be ‘0’ or ‘1’), followed by the new-line character. The characters are given in the order in which they appear in the S-tree, the first character corresponds to the leftmost terminal node of the S-tree, the last one to its rightmost terminal node. The next line contains a single integer m, the number of VVAs, followed by m lines describing them. Each of the m lines contains exactly n characters (each of which can be ‘0’ or ‘1’), followed by a new-line character. Regardless of the variable ordering of the S-tree, the first character always describes the value of x1, the second character describes the value of x2, and so on. So, the line 110 corresponds to the VVA (x1 = 1, x2 = 1, x3 = 0). The input is terminated by a test case starting with n = 0. This test case should not be processed.
Output
For each S-tree, output the line ‘S-Tree #j:’, where j is the number of the S-tree. Then print a line that contains the value of f(x1,x2,...,xn) for each of the given m VVAs, where f is the function defined by the S-tree. Output a blank line after each test case.
Sample Input
3
x1 x2 x3
00000111
4
000
010
111
110
3
x3 x1 x2
00010011
4
000
010
111
110
0
Sample Output
S-Tree #1: 0011
S-Tree #2: 0011
这道题用完全二叉树可以解决,但是我还是给大家说题意:给你一个序列的集合,也就是x1,x2的那些,然后告诉你树的高度(n)。每个叶子节点都有一个值,然后让你在根开始出发,0向左走,1向右走,然后输出路径就可以了。但是呢其实你碰到0,就*2,碰到1就*2+1,更简单(因为他和二进制等效)。
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
char a[8][2],b[10101],c[1010],d[10];
int main()
{
int flag=1;
int n;
while(~scanf("%d",&n)&&n)
{
memset(b,0,sizeof(b));
for(int i=0;i<n;i++)
scanf("%s",a[i]);
scanf("%s",c+1);
int m,k=0;
scanf("%d",&m);
for(int i=0;i<m;i++)
{
int x=1;
scanf("%s",d);
int l=strlen(d);
for(int j=0;j<l;j++)
{
if(d[j]=='0')
x*=2;
else
x=x*2+1;
}
b[k++]=c[x-(1<<n)+1];
}
printf("S-Tree #%d:\n",flag++);
printf("%s\n\n",b);
}
return 0;
}