素数的判定方法

举个例题啊

Primes

Write a program to read in a list of integers and determine whether or not each number is prime. A number, n, is prime if its only divisors are 1 and n. For this problem, the numbers 1 and 2 are not considered primes.

Input

Each input line contains a single integer. The list of integers is terminated with a number<= 0. You may assume that the input contains at most 250 numbers and each number is less than or equal to 16000.

Output

The output should consists of one line for every number, where each line first lists the problem number, followed by a colon and space, followed by "yes" or "no".

Sample Input

1
2
3
4
5
17
0

Sample Output

1: no
2: no
3: yes
4: no
5: yes
6: yes

这道题意思很简单就是判断素数问题,但是这个答案输出有毒,我错了七遍,同样的一个代码思路就卡在他那个倒霉的输出!

#include<stdio.h>
int cn(long long x)
{
    if(x<=1) return 0;
    if(x==2||x==3) return 1;
    if(x%6!=1&&x%6!=5) return 0;
    for(long long i=5; i*i<=x; i+=6)
        if(x%i==0||x%(i+2)==0) return 0;
    return 1;
}
int main()
{
    int n,m=1;
    while(~scanf("%d",&n)&&n)
    {
        if(n==1||n==2) printf("%d: no\n",m++);
        else if(n>2)
        {
            if(!cn(n)) printf("%d: no\n",m++);
            else printf("%d: yes\n",m++);
        }
    }
    return 0;
}
 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值