【ZOJ 2968】Difference Game

Now you are going to play an interesting game. In this game, you are given two groups of distinct integers and C coins. The two groups, named Ga and Gb respectively, are not empty and contain the same number of integers at first. Each time you can move one integer in one group to the other group. But a move that makes a group empty is considered as invalid. Each move will cost you p coins, and p equals the difference of the size between the two group (take the absolute value. e.g. moving a number from the group of size 4 to the group of size 6 will cost you |4 - 6| = 2 coins, and moving a number between two group with same size will not cost any coins). You can do as many moves as you wish, so long as the total cost does not exceed C.

Let M be the minimum integer in Ga, and N be the maximum integer in Gb. The purpose of this game is to produce a maximum (M - N).

Input

Standard input will contain multiple test cases. The first line of the input is a single integer T (1 <= T <= 60) which is the number of test cases. And it will be followed by T consecutive test cases.

Each case begin with two integers S (1 <= S <= 20000, indicating the size of Ga and Gb at first) and C (0 <= C <= 1000000). Two lines of S integers follow, representing the numbers in Ga and Gb respectively. All these integers are distinct and are between 1 and 50000, both inclusive.

Output

Results should be directed to standard output. The output of each test case should be a single integer in one line, which is the maximum possible value for M - N after some moves.

Sample Input

 

2
1 10
10
12
2 10
1 2
3 4

 

Sample Output

 

-2
1

 

Hint

For Sample 1, two groups are of size 1, so no moves can be done because any moving will make Ga or Gb empty, which is not valid. So M = 10, N = 12, M - N = -2.
For Sample 2, one valid steps of moves is:
Move 1 in Ga to Gb, cost 0 coins.
Move 3 in Gb to Ga, cost 2 coins.
Move 4 in Gb to Ga, cost 0 coins.
Then Ga contains 2 3 4, Gb contains 1, M = 2, N = 1, M - N = 1. This is the maximum possible value.

题意:

两个容器a、b,各装有s个数,所有数字都不相同。有c个硬币。每次可以花费两容器数字个数之差(abs(a.size()-b.size())的硬币,把数从一个容器移动到另一个容器里。

求a中数字的最小值减b中数字的最大值。

思路:

两种情况。

  1. 答案为正数。对2s个数排序,最终结果肯定是某一个间隔值。另a容器放置最大的i个数,b容器放置剩下的数,枚举i。设aa为a往b中移动的数字个数,bb为b往a中移动的数字个数,则花费cost=min(aa,bb)*2+abs(bb-aa)*(abs(bb-aa)-1)。因为移动时先以互换的方式(0 2 0 2.......)的移动,最后多出来的一部分再移动过去。只要cost<=c,就跟之前求的答案取个最大值就好了。
  2. 答案为负数。给a,b中的数分别排序。以互换的方式(0 2 0 2.......)进行移动。最后可以某个容器多移动一次,消耗0。a多移动一次和b多移动一次取个最大值。

 

代码:

#include<iostream>
#include<cstdio>
#include<cmath>
#include<algorithm>
using namespace std;
const int N=4e4+100;
int a[N],b[N];
struct node{
	int v;
	int type;
}mp[N];
bool cmp(node a,node b){
	return a.v>b.v;
}
int main(){
	int t,s,c,x,maxx,aa,bb,flag,num;
	scanf("%d",&t);
	while(t--){
		scanf("%d%d",&s,&c);
		for(int i=0;i<s;++i){
			scanf("%d",&a[i]);
			mp[i].v=a[i];
			mp[i].type=1;
		}
		for(int i=0;i<s;++i){
			scanf("%d",&b[i]);
			mp[i+s].v=b[i];
			mp[i+s].type=2;
		}
		sort(a,a+s);
		sort(b,b+s);
		sort(mp,mp+s+s,cmp);
		maxx=a[0]-b[s-1];
		flag=0;
		if(s>1){
			x=c/2;
			num=0;			
			for(int i=0;i<s+s-1;++i){
				if(mp[i].type==1)num++;
				aa=s-num;
				bb=i+1-num;
				if(min(aa,bb)*2+abs(bb-aa)*(abs(bb-aa)-1)<=c)
					maxx=max(maxx,mp[i].v-mp[i+1].v),flag=1;
			}
			if(flag==0)maxx=max(maxx,max(a[x+1]-b[s-1-x],a[x]-b[s-1-(x+1)]));
		}
		printf("%d\n",maxx);
	}
	return 0;
}

 

 

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
东南亚位于我国倡导推进的“一带一路”海陆交汇地带,作为当今全球发展最为迅速的地区之一,近年来区域内生产总值实现了显著且稳定的增长。根据东盟主要经济体公布的最新数据,印度尼西亚2023年国内生产总值(GDP)增长5.05%;越南2023年经济增长5.05%;马来西亚2023年经济增速为3.7%;泰国2023年经济增长1.9%;新加坡2023年经济增长1.1%;柬埔寨2023年经济增速预计为5.6%。 东盟国家在“一带一路”沿线国家中的总体GDP经济规模、贸易总额与国外直接投资均为最大,因此有着举足轻重的地位和作用。当前,东盟与中国已互相成为双方最大的交易伙伴。中国-东盟贸易总额已从2013年的443亿元增长至 2023年合计超逾6.4万亿元,占中国外贸总值的15.4%。在过去20余年中,东盟国家不断在全球多变的格局里面临挑战并寻求机遇。2023东盟国家主要经济体受到国内消费、国外投资、货币政策、旅游业复苏、和大宗商品出口价企稳等方面的提振,经济显现出稳步增长态势和强韧性的潜能。 本调研报告旨在深度挖掘东南亚市场的增长潜力与发展机会,分析东南亚市场竞争态势、销售模式、客户偏好、整体市场营商环境,为国内企业出海开展业务提供客观参考意见。 本文核心内容: 市场空间:全球行业市场空间、东南亚市场发展空间。 竞争态势:全球份额,东南亚市场企业份额。 销售模式:东南亚市场销售模式、本地代理商 客户情况:东南亚本地客户及偏好分析 营商环境:东南亚营商环境分析 本文纳入的企业包括国外及印尼本土企业,以及相关上下游企业等,部分名单 QYResearch是全球知名的大型咨询公司,行业涵盖各高科技行业产业链细分市场,横跨如半导体产业链(半导体设备及零部件、半导体材料、集成电路、制造、封测、分立器件、传感器、光电器件)、光伏产业链(设备、硅料/硅片、电池片、组件、辅料支架、逆变器、电站终端)、新能源汽车产业链(动力电池及材料、电驱电控、汽车半导体/电子、整车、充电桩)、通信产业链(通信系统设备、终端设备、电子元器件、射频前端、光模块、4G/5G/6G、宽带、IoT、数字经济、AI)、先进材料产业链(金属材料、高分子材料、陶瓷材料、纳米材料等)、机械制造产业链(数控机床、工程机械、电气机械、3C自动化、工业机器人、激光、工控、无人机)、食品药品、医疗器械、农业等。邮箱:market@qyresearch.com

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值