An Easy Problem

描述     In this problem, you are given two integers L and R, and your task is to calculate the sum of all the number's square between L and R(inclusive).
输入
The first line contains an integer T, indicates the number of test case.
The next T lines, each line contains two integers L and R(1≤L,R≤10^5).
输出
Print an integer represents the sum.
样例输入
2
1 2
2 4

样例输出

5

29

//代码如下

#include<iostream>
#include<stdio.h>
using namespace std;
int main()
{
	int n;
	double a,b,i,sum;
	while(cin>>n)
	{
		while(n--)
		{
			cin>>a>>b;
			sum=0;
			if(a>b) swap(a,b);
			for(i=a;i<=b;i++)
				sum+=i*i;
			printf("%.lf\n",sum);//此处不能用cout,因为数较大,不能完整的输出
		}
	}
	return 0;
}

//参考别人的代码(用的是long long型的)


#include <cstdio>
#include <algorithm>
using namespace std;
typedef long long LL;
inline LL get_sum(LL x) 
{
    return x * (x + 1) * (2 * x + 1) / 6;//从1到x的平方的和的公式
}
int main() 
{
    int T;
    LL L, R;
    scanf("%d", &T);
    while(T--) 
	{
        scanf("%lld%lld",&L, &R);
        if(L > R) swap(L, R);
        printf("%lld\n", get_sum(R) - get_sum(L - 1));
    }
    return 0;
}



转载于:https://www.cnblogs.com/NYNU-ACM/p/4237316.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值