Longge's problem 隐含了错误 WA

Description

Longge is good at mathematics and he likes to think about hard mathematical problems which will be solved by some graceful algorithms. Now a problem comes: Given an integer N(1 < N < 2^31),you are to calculate ∑gcd(i, N) 1<=i <=N. 

"Oh, I know, I know!" Longge shouts! But do you know? Please solve it. 

Input

Input contain several test case. 
A number N per line. 

Output

For each N, output ,∑gcd(i, N) 1<=i <=N, a line

Sample Input

2
6

Sample Output

3
15


#include<cctype>
#include<cmath>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<string>
#include<queue>
#include<stack>
#include<set>
#include<map>
#define REP(i,a,b) for (i=(a);i<=(b);i++)
#define CLEAR(a) memset((a),0,sizeof((a)))

using namespace std;

typedef long long LL;
const double pi = acos(-1.0);
const int maxn = 1e7+10;
const int maxm = 1e3;
const int inf = 99999999;
const float eps = 1e-3;

vector<int> vec;
vector<pair<int,int> > idx;

bool vis[maxn];
int n, L, G;
LL ans;

void init();
void solve();
void outp();

void get_prime()
{
    vec.clear();
    CLEAR(vis);
    int k = 0;
    for (int i = 2; i < maxn; i++)
    {
        if (!vis[i])
        {
            vec.push_back(i);
        }
        for (int j = 1; j <= vec.size() && i * vec[j - 1] <= maxn; j++)
        {
            vis[i * vec[j - 1]] = 1;
        }
    }
}

void get_pfactor(int n)
{
    idx.clear();
    for (int k = 0; vec[k]*vec[k] <= n && k < vec.size(); k++)
    {
        int e = 0;
        while (!(n % vec[k]))
        {
            n /= vec[k];
            e++;
        }
        if (e)
        {
            idx.push_back(make_pair(vec[k],e));
        }
    }
    if (n > 1)
    {
        idx.push_back(make_pair(n,1));
    }
}


int main()
{
    get_prime();

    while (~scanf("%d",&n))
    {
        init();
        solve();
        outp();
    }
    return 0;
}

void solve()
{
    get_pfactor(n);
    int sum = idx.size();
    for (int i = 0; i < sum; i++)
    {
        LL p = idx[i].second;
        LL tmp = (p + 1) * (p + 1) * (p + 1);
        tmp += (p - 1) * (p - 1) * (p - 1);
        tmp -= 2 * p * p * p;
        ans *= tmp;
    }
}

void init()
{
}

void outp()
{
    printf("%I64d\n", ans);
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值