Hopscotch
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions:4853 | Accepted: 3212 |
Description
The cows play the child's game of hopscotch in a non-traditional way. Instead of a linear set of numbered boxes into which to hop, the cows create a 5x5 rectilinear grid of digits parallel to the x and y axes.
They then adroitly hop onto any digit in the grid and hop forward, backward, right, or left (never diagonally) to another digit in the grid. They hop again (same rules) to a digit (potentially a digit already visited).
With a total of five intra-grid hops, their hops create a six-digit integer (which might have leading zeroes like 000201).
Determine the count of the number of distinct integers that can be created in this manner.
They then adroitly hop onto any digit in the grid and hop forward, backward, right, or left (never diagonally) to another digit in the grid. They hop again (same rules) to a digit (potentially a digit already visited).
With a total of five intra-grid hops, their hops create a six-digit integer (which might have leading zeroes like 000201).
Determine the count of the number of distinct integers that can be created in this manner.
Input
* Lines 1..5: The grid, five integers per line
Output
* Line 1: The number of distinct integers that can be constructed
Sample Input
1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 2 1 1 1 1 1 1
Sample Output
15
Hint
OUTPUT DETAILS:
111111, 111112, 111121, 111211, 111212, 112111, 112121, 121111, 121112, 121211, 121212, 211111, 211121, 212111, and 212121 can be constructed. No other values are possible.
111111, 111112, 111121, 111211, 111212, 112111, 112121, 121111, 121112, 121211, 121212, 211111, 211121, 212111, and 212121 can be constructed. No other values are possible.
遍历从每个点出发的情况,一共六个数,可以直接转化成一个
六位数存到数组里。
代码:
#include<cstdio>
#include<string.h>
#include<queue>
int d[4][2]={{1,0},{-1,0},{0,1},{0,-1}};
bool mp[1000002];
using namespace std;
struct node
{
int dec,sum,x,y;
};
queue<node>P;
int main()
{
int a[6][6],i,j,ans=0;
memset(mp,0,sizeof(mp));
for(i=1; i<=5; i++)
for(j=1; j<=5; j++)
scanf("%d",&a[i][j]);
for(i=1; i<=5; i++)
for(j=1; j<=5; j++)
{
node r;r.dec=1,r.sum=a[i][j];
r.x=i,r.y=j;P.push(r);
while(!P.empty())
{
r=P.front();P.pop();
if(r.dec==6)
{
if(!mp[r.sum])
{
ans++;mp[r.sum]=1;
}
continue;
}
for(int k=0;k<4;k++)
{
int x=r.x+d[k][0],y=r.y+d[k][1];
if(x>=1&&x<=5&&y>=1&&y<=5)
{
node e;e.dec=r.dec+1;e.sum=r.sum*10+a[x][y];
e.x=x;e.y=y;
P.push(e);
}
}
}
}
printf("%d\n",ans);
return 0;
}