Hopscotch(POJ-3050)

题目:

The cows play the child’s game of hopscotch in a non-traditional way. Instead of a linear set of numbered boxes into which to hop, the cows create a 5x5 rectilinear grid of digits parallel to the x and y axes They then adroitly hop onto any digit in the grid and hop forward, backward, right, or left (never diagonally) to another digit in the grid. They hop again (same rules) to a digit
(potentially a digit already visited).
With a total of five intra-grid hops, their hops create a six-digit integer (which might have leading zeroes like 000201).
Determine the count of the number of distinct integers that can be created in this manner.
Input
* Lines 1…5: The grid, five integers per line
Output
* Line 1: The number of distinct integers that can be constructed
Sample Input

1 1 1 1 1
1 1 1 1 1
1 1 1 1 1
1 1 1 2 1
1 1 1 1 1

Sample Output

15

解题思路:深搜的题目,分别从5^5的矩阵各个顶点上下左右出发,然后走六步组成一个六位数,判断能组成多少个不同的六位数
注意:每组成一个六位数就要标记一下,所以数组至少要开七位。

程序代码:

#include<stdio.h>
#include<string.h>
int n=0;
int a[15][15],book[15][15],f[10000010];//因为要组成六位数,所以数组至少要开七位
int next[4][2]={{0,1},{1,0},{0,-1},{-1,0}};
void dfs(int x,int y,int t,int sum)
{
	int i,j,k,tx,ty;
	if(t==5)
	{
		if(f[sum]==0)
			n++;
		f[sum]=1;
		return;
	}
	for(k=0;k<=3;k++)
	{
		tx=x+next[k][0];
		ty=y+next[k][1];
		if(tx<1||tx>5||ty<1||ty>5)
			continue;
		dfs(tx,ty,t+1,sum*10+a[tx][ty]);
	}
	return;
}
int main()
{
	int i,j,k,t,sum;
	for(i=1;i<=5;i++)
		for(j=1;j<=5;j++)
			scanf("%d",&a[i][j]);
	for(i=1;i<=5;i++)
		for(j=1;j<=5;j++)
			dfs(i,j,0,a[i][j]);
	printf("%d\n",n);
	return 0;		
} 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

我菜就爱学

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值