POJ 3614 Sunscreen(贪心)

Sunscreen
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions:9946 Accepted: 3465

Description

To avoid unsightly burns while tanning, each of the C (1 ≤ C ≤ 2500) cows must cover her hide with sunscreen when they're at the beach. Cow i has a minimum and maximum SPF rating (1 ≤ minSPFi ≤ 1,000; minSPFi ≤ maxSPFi ≤ 1,000) that will work. If the SPF rating is too low, the cow suffers sunburn; if the SPF rating is too high, the cow doesn't tan at all........

The cows have a picnic basket with L (1 ≤ L ≤ 2500) bottles of sunscreen lotion, each bottle i with an SPF rating SPFi (1 ≤ SPFi ≤ 1,000). Lotion bottle i can cover coveri cows with lotion. A cow may lotion from only one bottle.

What is the maximum number of cows that can protect themselves while tanning given the available lotions?

Input

* Line 1: Two space-separated integers: C and L
* Lines 2..C+1: Line i describes cow i's lotion requires with two integers: minSPFi and maxSPFi 
* Lines C+2..C+L+1: Line i+C+1 describes a sunscreen lotion bottle i with space-separated integers: SPFi and coveri

Output

A single line with an integer that is the maximum number of cows that can be protected while tanning

Sample Input

3 2
3 10
2 5
1 5
6 2
4 1

Sample Output

2
#include<cstdio>
#include<algorithm>
#include<queue>
#include<vector>
using namespace std;
struct node
{
    int x,y;
};
node cow[2505],r[2505];
bool cmp(node a,node b)
{
    return a.x<b.x;
}
priority_queue<int,vector<int>,greater<int> >P;
int main()
{
    int n,m,i,j;scanf("%d%d",&n,&m);
    for(i=1;i<=n;i++)
        scanf("%d%d",&cow[i].x,&cow[i].y);
    for(i=1;i<=m;i++)
        scanf("%d%d",&r[i].x,&r[i].y);
    sort(cow+1,cow+n+1,cmp);
    sort(r+1,r+m+1,cmp);
    j=1;int ans=0;
    for(i=1;i<=m;i++)
    {
        int x=r[i].x,num=r[i].y;
        for( ;j<=n;j++)
        {
            if(cow[j].x>x)break;
            P.push(cow[j].y);
        }
        if(!P.empty())
        {
            for(int k=1;k<=num;k++)
            {
                if(P.empty())break;
                if(P.top()<x)k--;
                else ans++;
                P.pop();
            }
        }
    }
    printf("%d\n",ans);
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值