POJ 3685 Matrix

Matrix
Time Limit: 6000MS Memory Limit: 65536K
Total Submissions:7731 Accepted: 2320

Description

Given a N × N matrix A, whose element in the i-th row and j-th column Aij is an number that equals i2 + 100000 × i + j2 - 100000 × j + i × j, you are to find the M-th smallest element in the matrix.

Input

The first line of input is the number of test case.
For each test case there is only one line contains two integers, N(1 ≤ N ≤ 50,000) and M(1 ≤ M ≤ N × N). There is a blank line before each test case.

Output

For each test case output the answer on a single line.

Sample Input

12

1 1

2 1

2 2

2 3

2 4

3 1

3 2

3 8

3 9

5 1

5 25

5 10

Sample Output

3
-99993
3
12
100007
-199987
-99993
100019
200013
-399969
400031

-99939

j确定时i增加,值相应增加。因此对每个确定的j,二分找到i
代码:

#include<cstdio>
using namespace std;
long long pp(long long j,long long n,long long t)
{
    long long q=0,r=n+1;
    while(r-q>1)
    {
        long long i=(q+r)/2;
        long long s=i*i+100000*i+j*j-100000*j+i*j;
        if(s>=t) r=i;
        else q=i;
    }
    return q;
}
int main()
{
    int T;scanf("%d",&T);
    while(T--)
    {
        long long n,m;scanf("%lld%lld",&n,&m);
        long long q=-1e12,r=1e12;//千万不要忘记可以是负值,
                                 //有wa了好久
        while(r-q>1)
        {
            long long mid=(r+q)/2,s=0;
            for(long long j=1;j<=n;j++)
            {
                s+=pp(j,n,mid);
            }
            if(s<m) q=mid;
            else r=mid;
        }
        printf("%lld\n",q);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值