POJ3685-Matrix

44 篇文章 0 订阅

Matrix
Time Limit: 6000MS Memory Limit: 65536K
Total Submissions: 6722 Accepted: 1958

Description

Given a N × N matrix A, whose element in the i-th row and j-th column Aij is an number that equals i2 + 100000 × i + j2 - 100000 × j + i × j, you are to find the M-th smallest element in the matrix.

Input

The first line of input is the number of test case.
For each test case there is only one line contains two integers, N(1 ≤ N ≤ 50,000) and M(1 ≤ M ≤ N × N). There is a blank line before each test case.

Output

For each test case output the answer on a single line.

Sample Input

12

1 1

2 1

2 2

2 3

2 4

3 1

3 2

3 8

3 9

5 1

5 25

5 10

Sample Output

3
-99993
3
12
100007
-199987
-99993
100019
200013
-399969
400031
-99939

Source



题意:n阶矩阵Aij= i*i + 100000 × i + j*j – 100000 × j + i × j,求第m小的元素

解题思路:我先打n为比较小的表,发现很有规律,大小规律是从右上往左下依次增大,但是wa了,据说这个规律到n为5*10^4就不一定保持了。所以这题应该二分第m小的数,又因为 i*i + 100000 × i + j*j – 100000 × j + i × j是关于i递增的,再次二分每一列,找到比它小的数


#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <queue>
#include <cmath>
#include <map>
#include <bitset>
#include <set>
#include <vector>
#include <functional>

using namespace std;

#define LL long long
const LL INF=0x3f3f3f3f3f3f3f3f;

LL m,n;

bool check(LL x)
{
    LL sum=0;
    for(LL i=1;i<=n;i++)
    {
        LL l=1,r=n,ans=0;
        while(l<=r)
        {
            LL mid=(l+r)/2;
            if(mid*mid+100000*mid+i*i-100000*i+mid*i<=x) {ans=mid,l=mid+1;}
            else r=mid-1;
        }
        sum+=ans;
    }
    if(sum>=m) return 1;
    else return 0;
}

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%lld%lld",&n,&m);
        LL l=-INF,r=INF,ans;
        while(l<=r)
        {
            LL mid=(l+r)/2;
            if(check(mid)) {ans=mid;r=mid-1;}
            else l=mid+1;
        }
        printf("%lld\n",ans);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值