POJ 1990 MooFest(树状数组)

MooFest
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions:8934 Accepted: 4033

Description

Every year, Farmer John's N (1 <= N <= 20,000) cows attend "MooFest",a social gathering of cows from around the world. MooFest involves a variety of events including haybale stacking, fence jumping, pin the tail on the farmer, and of course, mooing. When the cows all stand in line for a particular event, they moo so loudly that the roar is practically deafening. After participating in this event year after year, some of the cows have in fact lost a bit of their hearing. 

Each cow i has an associated "hearing" threshold v(i) (in the range 1..20,000). If a cow moos to cow i, she must use a volume of at least v(i) times the distance between the two cows in order to be heard by cow i. If two cows i and j wish to converse, they must speak at a volume level equal to the distance between them times max(v(i),v(j)). 

Suppose each of the N cows is standing in a straight line (each cow at some unique x coordinate in the range 1..20,000), and every pair of cows is carrying on a conversation using the smallest possible volume. 

Compute the sum of all the volumes produced by all N(N-1)/2 pairs of mooing cows. 

Input

* Line 1: A single integer, N 

* Lines 2..N+1: Two integers: the volume threshold and x coordinate for a cow. Line 2 represents the first cow; line 3 represents the second cow; and so on. No two cows will stand at the same location. 

Output

* Line 1: A single line with a single integer that is the sum of all the volumes of the conversing cows. 

Sample Input

4
3 1
2 5
2 6
4 3

Sample Output

57

根据v的值从小到大排序,第i头牛时只需计算与前i-1头牛的值即可,
a[i]存储的时牛的数量,sum(i,a)返回的是i位置之前有多少头牛,
因此便可以对i的前后分别求和

代码:

#include<cstdio>
#include<algorithm>
using namespace std;
const int maxn=20007;
#define ll long long
ll s[maxn];
ll a[maxn];
ll n;
struct node
{
    ll v,id;
}c[maxn];
bool cmp(const node& a,const node& b)
{
    return a.v<b.v;
}
ll sum(ll i,ll *t)
{
    ll ans=0;
    while(i>0)
    {
        ans+=t[i];
        i-=i&-i;
    }
    return ans;
}
void add(ll i,ll c,ll *t)
{
    while(i<=maxn)
    {
        t[i]+=c;
        i+=i&-i;
    }
}
int main()
{
    int i,j;scanf("%lld",&n);
    for(i=1;i<=n;i++)
        scanf("%lld%lld",&c[i].v,&c[i].id);
    sort(c+1,c+n+1,cmp);
    ll ans=0;
    for(i=1;i<=n;i++)
    {
        ll num=sum(c[i].id,a);
        add(c[i].id,1,a);
        ans+=(num*c[i].id-sum(c[i].id,s))*c[i].v;
        ans+=(sum(20000,s)-sum(c[i].id,s)-(i-num-1)*c[i].id)*c[i].v;
        add(c[i].id,c[i].id,s);
    }
    printf("%lld\n",ans);
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值