SCU 4440 Rectangle(dp)

Rectangle

frog has a piece of paper divided into nn rows and mm columns. Today, she would like to draw a rectangle whose perimeter is not greater than kk.

There are 8 (out of 9) ways when n = m = 2, k = 6

There are 88 (out of 99) ways when n=m=2,k=6n=m=2,k=6

Find the number of ways of drawing.

Input

The input consists of multiple tests. For each test:

The first line contains 33 integer n,m,kn,m,k (1n,m5104,0k1091≤n,m≤5⋅104,0≤k≤109).

Output

For each test, write 11 integer which denotes the number of ways of drawing.

Sample Input

    2 2 6
    1 1 0
    50000 50000 1000000000

Sample Output

    8
    0
    1562562500625000000
#include<bits/stdc++.h>
using namespace std;
#define ll long long
const int maxn=1e5+7;
ll n,m,k;
ll a[maxn];
int main()
{
	while(~scanf("%lld%lld%lld",&n,&m,&k))
	{
		for(int i=1;i<=m;i++)a[i]=a[i-1]+m-i+1;
		ll t=0,ans=0;
		for(ll i=1;i<=n;i++)
		{
			ll id=min((k-2*i)/2,m);
			if(id<0)id=0;
			t+=a[id];
			ans+=t;
		}
		printf("%lld\n",ans);
	}
	return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值