HDU 2196 Computer

Computer

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 32564    Accepted Submission(s): 4595


Problem Description
A school bought the first computer some time ago(so this computer's id is 1). During the recent years the school bought N-1 new computers. Each new computer was connected to one of settled earlier. Managers of school are anxious about slow functioning of the net and want to know the maximum distance Si for which i-th computer needs to send signal (i.e. length of cable to the most distant computer). You need to provide this information. 


Hint: the example input is corresponding to this graph. And from the graph, you can see that the computer 4 is farthest one from 1, so S1 = 3. Computer 4 and 5 are the farthest ones from 2, so S2 = 2. Computer 5 is the farthest one from 3, so S3 = 3. we also get S4 = 4, S5 = 4.
 

Input
Input file contains multiple test cases.In each case there is natural number N (N<=10000) in the first line, followed by (N-1) lines with descriptions of computers. i-th line contains two natural numbers - number of computer, to which i-th computer is connected and length of cable used for connection. Total length of cable does not exceed 10^9. Numbers in lines of input are separated by a space.
 

Output
For each case output N lines. i-th line must contain number Si for i-th computer (1<=i<=N).
 

Sample Input
 
 
5 1 1 2 1 3 1 1 1
 

Sample Output
 
 
3 2 3 4 4
 
题解:
每一个点的最长路是此点到所有子节点的最长距离,或者到其父亲节点在加上
父亲节点到子节点的最大值。
#include<bits/stdc++.h>
using namespace std;
const int maxn=10005;
struct node
{
    int to,cost,next;
}rode[3*maxn];
int tol,d1[maxn],d2[maxn],id1[maxn],id2[maxn],head[maxn];
void add(int a,int b,int c)
{
    rode[tol].to=b;
    rode[tol].cost=c;
    rode[tol].next=head[a];
    head[a]=tol++;
}
void dfs1(int rt)
{
    d1[rt]=d2[rt]=0;
    for(int i=head[rt];i!=-1;i=rode[i].next)
    {
        node e=rode[i];
        dfs1(e.to);
        if(d1[e.to]+e.cost>d2[rt])
        {
            d2[rt]=d1[e.to]+e.cost;
            id2[rt]=e.to;
            if(d2[rt]>d1[rt])
            {
                swap(d1[rt],d2[rt]);
                swap(id1[rt],id2[rt]);
            }
        }
    }
}
void dfs2(int rt)
{
    for(int i=head[rt];i!=-1;i=rode[i].next)
    {
        node e=rode[i];
        if(id1[rt]==e.to)
        {
            if(d2[e.to]<d2[rt]+e.cost)
            {
                d2[e.to]=d2[rt]+e.cost;
                id2[e.to]=rt;
                if(d2[e.to]>d1[e.to])
                {
                    swap(d1[e.to],d2[e.to]);
                    swap(id1[e.to],id2[e.to]);
                }
            }
        }
        else
        {
            if(d2[e.to]<d1[rt]+e.cost)
            {
                d2[e.to]=d1[rt]+e.cost;
                id2[e.to]=rt;
                if(d2[e.to]>d1[e.to])
                {
                    swap(d1[e.to],d2[e.to]);
                    swap(id1[e.to],id2[e.to]);
                }
            }
        }
        dfs2(e.to);
    }
}
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        tol=0;
        memset(head,-1,sizeof(head));
        memset(d1,0,sizeof(d1));
        memset(d2,0,sizeof(d2));
        for(int i=2;i<=n;i++)
        {
            int x,y;scanf("%d%d",&x,&y);
            add(x,i,y);
        }
        dfs1(1);
        dfs2(1);
        for(int i=1;i<=n;i++)
            printf("%d\n",d1[i]);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值