HDU 2196 Computer(树状DP)

34 篇文章 0 订阅
1 篇文章 0 订阅

Computer

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6841 Accepted Submission(s): 3415

Problem Description
A school bought the first computer some time ago(so this computer’s id is 1). During the recent years the school bought N-1 new computers. Each new computer was connected to one of settled earlier. Managers of school are anxious about slow functioning of the net and want to know the maximum distance Si for which i-th computer needs to send signal (i.e. length of cable to the most distant computer). You need to provide this information.

Hint: the example input is corresponding to this graph. And from the graph, you can see that the computer 4 is farthest one from 1, so S1 = 3. Computer 4 and 5 are the farthest ones from 2, so S2 = 2. Computer 5 is the farthest one from 3, so S3 = 3. we also get S4 = 4, S5 = 4.

Input
Input file contains multiple test cases.In each case there is natural number N (N<=10000) in the first line, followed by (N-1) lines with descriptions of computers. i-th line contains two natural numbers - number of computer, to which i-th computer is connected and length of cable used for connection. Total length of cable does not exceed 10^9. Numbers in lines of input are separated by a space.

Output
For each case output N lines. i-th line must contain number Si for i-th computer (1<=i<=N).

Sample Input
5
1 1
2 1
3 1
1 1

Sample Output
3
2
3
4
4

题意:求一个树中各个节点能到达的最远距离。

题解:两次dfs,第一个dfs求出所有每个节点i在其子树中的正向最大距离和正向次大距离。第二个dfs找出每个点的父亲可以到达的最大距离。

代码:

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <vector>

using namespace std;
const int maxn = 10005;
int dp[maxn][3];
struct Node
{
    int to;
    int cost;
}node;
vector<Node> v[maxn];
int n;

void dfs1(int p,int f)
{
    int a = 0, b = 0;
    for (int i = 0;i < v[p].size();i++)
    {
        int m = v[p][i].to;
        if (m == f)
            continue;
        dfs1(m, p);
        if (dp[m][0] + v[p][i].cost > a)
        {
            b = a;
            a = dp[m][0] + v[p][i].cost;
        }
        else if (dp[m][0] + v[p][i].cost > b)
            b = dp[m][0] + v[p][i].cost;
    }
    dp[p][0] = a;
    dp[p][1] = b;

}
void dfs2(int p,int f)
{
    int t;
    for (int i= 0;i < v[p].size();i++)
    {
        int m = v[p][i].to;
        if (m == f)
            continue;
        if (dp[p][0] == dp[m][0] + v[p][i].cost)
            t = dp[p][1];
        else t = dp[p][0];
        dp[m][2] = max(dp[p][2], t) + v[p][i].cost;
        dfs2(m, p);
    }
}
int main()
{
    while (cin >> n)
    {
        memset(dp, 0, sizeof(dp));
        for (int i = 0;i < maxn;i++)
        {
            v[i].clear();
        }
        for (int i = 2;i<=n;i++)
        {
            int tmp;
             cin >> tmp >> node.cost;
             node.to = tmp;
             v[i].push_back(node);
             node.to = i;
             v[tmp].push_back(node);
        }
        dfs1(1, -1);
        dp[1][2] = 0;
        dfs2(1, -1);
        for (int i = 1;i <= n;i++)
        {
            cout << max(dp[i][2], dp[i][0]) << endl;
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Usher_Ou

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值