HDU 1724 Ellipse(辛普森积分)

Ellipse

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2749    Accepted Submission(s): 1240


 

Problem Description

Math is important!! Many students failed in 2+2’s mathematical test, so let's AC this problem to mourn for our lost youth..
Look this sample picture:



A ellipses in the plane and center in point O. the L,R lines will be vertical through the X-axis. The problem is calculating the blue intersection area. But calculating the intersection area is dull, so I have turn to you, a talent of programmer. Your task is tell me the result of calculations.(defined PI=3.14159265 , The area of an ellipse A=PI*a*b )

 

 

Input

Input may contain multiple test cases. The first line is a positive integer N, denoting the number of test cases below. One case One line. The line will consist of a pair of integers a and b, denoting the ellipse equation , A pair of integers l and r, mean the L is (l, 0) and R is (r, 0). (-a <= l <= r <= a).

 

 

Output

For each case, output one line containing a float, the area of the intersection, accurate to three decimals after the decimal point.

 

 

Sample Input

 

2 2 1 -2 2 2 1 0 2

 

 

Sample Output

 

6.283 3.142

 

#include<bits/stdc++.h>
using namespace std;
const double esp=1e-10;
double a,b,l,r;
double f(double x)
{
    return sqrt(b*b*(1-x*x/a/a));
}
double simpson(double x1,double x2)
{
    return (x2-x1)/6*(f(x1)+4*f((x1+x2)/2)+f(x2));
}
double cmp(double x1,double x2)
{
    double t=(x1+x2)/2;
    double s0=simpson(x1,x2);
    double s1=simpson(x1,t);
    double s2=simpson(t,x2);
    if(fabs(s1+s2-s0)<=esp) return s0;
    return cmp(x1,t)+cmp(t,x2);
}
int main()
{
    int T;scanf("%d",&T);
    while(T--)
    {
        scanf("%lf%lf%lf%lf",&a,&b,&l,&r);
        printf("%.3lf\n",2*cmp(l,r));
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值