hdu 1043 Eight(八数码问题,IDA*)

Eight

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 29904    Accepted Submission(s): 7850
Special Judge

 

Problem Description

The 15-puzzle has been around for over 100 years; even if you don't know it by that name, you've seen it. It is constructed with 15 sliding tiles, each with a number from 1 to 15 on it, and all packed into a 4 by 4 frame with one tile missing. Let's call the missing tile 'x'; the object of the puzzle is to arrange the tiles so that they are ordered as: 

 1  2  3  4
 5  6  7  8
 9 10 11 12
13 14 15  x


where the only legal operation is to exchange 'x' with one of the tiles with which it shares an edge. As an example, the following sequence of moves solves a slightly scrambled puzzle: 

 1  2  3  4     1  2  3  4     1  2  3  4     1  2  3  4
 5  6  7  8     5  6  7  8     5  6  7  8     5  6  7  8
 9  x 10 12     9 10  x 12     9 10 11 12     9 10 11 12
13 14 11 15    13 14 11 15    13 14  x 15    13 14 15  x
            r->            d->            r->


The letters in the previous row indicate which neighbor of the 'x' tile is swapped with the 'x' tile at each step; legal values are 'r','l','u' and 'd', for right, left, up, and down, respectively. 

Not all puzzles can be solved; in 1870, a man named Sam Loyd was famous for distributing an unsolvable version of the puzzle, and 
frustrating many people. In fact, all you have to do to make a regular puzzle into an unsolvable one is to swap two tiles (not counting the missing 'x' tile, of course). 

In this problem, you will write a program for solving the less well-known 8-puzzle, composed of tiles on a three by three 
arrangement.

 

 

Input

You will receive, several descriptions of configuration of the 8 puzzle. One description is just a list of the tiles in their initial positions, with the rows listed from top to bottom, and the tiles listed from left to right within a row, where the tiles are represented by numbers 1 to 8, plus 'x'. For example, this puzzle 

1 2 3 
x 4 6 
7 5 8 

is described by this list: 

1 2 3 x 4 6 7 5 8

 

 

Output

You will print to standard output either the word ``unsolvable'', if the puzzle has no solution, or a string consisting entirely of the letters 'r', 'l', 'u' and 'd' that describes a series of moves that produce a solution. The string should include no spaces and start at the beginning of the line. Do not print a blank line between cases.

 

 

Sample Input

 

2 3 4 1 5 x 7 6 8

 

 

Sample Output

 

ullddrurdllurdruldr

 

#include<bits/stdc++.h>
using namespace std;
char t[12],st[202];
char g[4]={'r','d','u','l'};//四个方向和d数组对应
int d[4][2]={{0,1},{1,0},{-1,0},{0,-1}};
int mp[12];
int h[10][2]={{2,2},{0,0},{0,1},{0,2},{1,0},{1,1},{1,2},{2,0},{2,1},{2,2}};
//h存储每个数字应该在的位置。
bool check()
{
    int sum=0;
    for(int i=0;i<9;i++)
    {
        if(!mp[i])continue;
        for(int j=i+1;j<9;j++)
            if(mp[i]>mp[j]&&mp[j]) sum++;
    }
    return sum%2==0;
}
int f()//计算曼哈顿距离
{
    int ans=0;
    for(int i=0;i<9;i++)
        if(mp[i])ans=ans+abs(h[mp[i]][0]-i/3)+abs(h[mp[i]][1]-i%3);
    return ans;
}
bool dfs(int x,int y,int pre,int step,int upper)
{
    for(int i=0;i<4;i++)
    {
        int xx=x+d[i][0],yy=y+d[i][1];
        if(xx<0||xx>=3||yy<0||yy>=3||pre+i==3)continue;//pre+i==3走回了原来的方向
        mp[x*3+y]=mp[xx*3+yy];
        mp[xx*3+yy]=0;
        int mht=f();
        if(mht==0)
        {
            st[step]=g[i];
            st[step+1]='\0';
            return 1;
        }
        if(mht+step+1<=upper)//剪枝
        {
            st[step]=g[i];
            if(dfs(xx,yy,i,step+1,upper))
                return 1;
        }
        mp[xx*3+yy]=mp[x*3+y];
        mp[x*3+y]=0;
    }
    return 0;
}
int main()
{
    while(cin>>t[0])
    {
        for(int i=1;i<9;i++)
            cin>>t[i];
        int x,y;
        for(int i=0;i<9;i++)
        {
            if(t[i]=='x')
            {
                mp[i]=0;
                x=i/3;y=i%3;
            }
            else mp[i]=t[i]-'0';
        }
        if(!check()) printf("unsolvable\n");
        else
        {
            int top=f();
            if(top==0) printf("\n");
            else
            {
                while(!dfs(x,y,-1,0,top)) top++;
                printf("%s\n",st);
            }
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值