PAT1085:Perfect Sequence

1085 Perfect Sequence (25 分)

Given a sequence of positive integers and another positive integer p. The sequence is said to be a perfect sequence if M≤m×p where M and m are the maximum and minimum numbers in the sequence, respectively.

Now given a sequence and a parameter p, you are supposed to find from the sequence as many numbers as possible to form a perfect subsequence.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive integers N and p, where N (≤10​5​​) is the number of integers in the sequence, and p (≤10​9​​) is the parameter. In the second line there are N positive integers, each is no greater than 10​9​​.

Output Specification:

For each test case, print in one line the maximum number of integers that can be chosen to form a perfect subsequence.

Sample Input:

10 8
2 3 20 4 5 1 6 7 8 9

Sample Output:

8

思路:

利用二分查找法,在待查元素的右边查找符和要求的元素

#include <iostream>
#include <algorithm>
#include <vector>
using namespace std;
const long MAXN = 100010;
long long a[MAXN];
long long p = 0;
long n = 0;

int binarySearch(int i, long long x) {
	if (a[n - 1] <= x) {
		return n;  //如果所有数字都小于的话,直接返回该数
	}
	int l = i + 1, r = n - 1;
	int mid;
	while (l < r) {
		mid = (l + r) / 2;
		if (a[mid] <= x) {
			l = mid + 1;
		}
		else {
			r = mid;
		}
	}
	return l; //返回中间位置元素
}


int main() {
	cin >> n;   //数字个数
	cin >> p;   //待乘的数

	for (long i = 0; i < n; ++i) {
		cin >> a[i];   //输入数字
	}
	sort(a, a + n); //排序
	
	int ans = 0;
	for (int i = 0; i < n; ++i) {
		long long comp = a[i] * p;   
		int j = binarySearch(i, comp);   //向右边二分查找最大的数
		ans = max(ans, j - i);
	}

	cout << ans << endl;
	
	system("PAUSE");
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值