1093 Count PAT's (25 分)
The string APPAPT
contains two PAT
's as substrings. The first one is formed by the 2nd, the 4th, and the 6th characters, and the second one is formed by the 3rd, the 4th, and the 6th characters.
Now given any string, you are supposed to tell the number of PAT
's contained in the string.
Input Specification:
Each input file contains one test case. For each case, there is only one line giving a string of no more than 105 characters containing only P
, A
, or T
.
Output Specification:
For each test case, print in one line the number of PAT
's contained in the string. Since the result may be a huge number, you only have to output the result moded by 1000000007.
Sample Input:
APPAPT
Sample Output:
2
解题思路:
我们通过观察得知:字符串中每个字符A左边P的个数和右边T的个数相乘就是一个字符A所能组成PAT字串的个数
所以我们遍历字符串,每得到一个字符A,求解字符左边P的个数和右边T的个数,相乘,遍历完所有的A后,累加所有相乘的结果
我们可以通过正推得到每个字符到当前位置为止字符P的个数
然后通过倒推得到每个字符到当前位置为止字符T的个数,同时别忘了最后根据题意进行取余操作
#include<iostream>
#include<string>
#include<string.h>
#include<algorithm>
using namespace std;
const int MAXN = 100010;
const int mod = 1000000007;
char PATS[MAXN];
int pre[MAXN] = { 0 }, back[MAXN] = { 0 };
int main() {
cin >> PATS;
int counter = 0;
int len = strlen(PATS);
for (int i = 0; i < len; ++i) {
if (i > 0) {
pre[i] += pre[i - 1]; //递推公式
}
if (PATS[i] == 'P') {
pre[i]++;
}
}
for (int j = len - 1; j >= 0; --j) {
if (j < len - 1) {
back[j] += back[j + 1];
}
if (PATS[j] == 'T') {
back[j]++;
}
}
for (int i = 0; i < len; ++i) {
if (PATS[i] == 'A') {
counter = (counter + (pre[i]%mod) * (back[i]%mod))%mod; //防止数组过大而进行取余
}
}
cout << counter;
return 0;
}