(PAT1100) Mars Numbers (利用map映射关系查找)

1100 Mars Numbers (20 point(s))

People on Mars count their numbers with base 13:

  • Zero on Earth is called "tret" on Mars.
  • The numbers 1 to 12 on Earch is called "jan, feb, mar, apr, may, jun, jly, aug, sep, oct, nov, dec" on Mars, respectively.
  • For the next higher digit, Mars people name the 12 numbers as "tam, hel, maa, huh, tou, kes, hei, elo, syy, lok, mer, jou", respectively.

For examples, the number 29 on Earth is called "hel mar" on Mars; and "elo nov" on Mars corresponds to 115 on Earth. In order to help communication between people from these two planets, you are supposed to write a program for mutual translation between Earth and Mars number systems.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<100). Then N lines follow, each contains a number in [0, 169), given either in the form of an Earth number, or that of Mars.

Output Specification:

For each number, print in a line the corresponding number in the other language.

Sample Input:

4
29
5
elo nov
tam

Sample Output:

hel mar
may
115
13

解题思路:

可以把题意中给出的火星文和其代表的数字存储到map中,在输入测试用例时,通过查表找到对应关系,然后进行相应的转换就行

我在这里犯了一个错,如果能直接输出进位数的话,就只需要输出进位数即可,不需要输出原位数,比如26/13=2,只需输出hel就行了,无需输出原位中的treat

#include <string>
#include <string.h>
#include <map>
#include <iostream>
using namespace std;
//int转string
string Basics[13] = { "tret", "jan", "feb", "mar", "apr", "may", "jun", "jly", "aug", "sep", "oct", "nov", "dec" };
string CarryOn[13] = { "tret","tam", "hel", "maa", "huh", "tou", "kes", "hei", "elo", "syy", "lok", "mer", "jou" };
//string转int
map<string, int> strToNum;
int main() {
	//打表
	for (int i = 0; i < 13; ++i) {
		strToNum[Basics[i]] = i;
	}
	for (int i = 0; i < 13; ++i) {
		strToNum[CarryOn[i]] = i;
	}
	//输入数字
	int N;
	cin >> N;
	string kong;
	getline(cin, kong);
	for (int i = 0; i < N; ++i) {
		string input;
		getline(cin, input);
		if (isdigit(input[0])) {
			int number = atoi(input.c_str());
			int carryOns = number / 13;
			int basics = number % 13;
			//这里要注意输出格式
			if (carryOns == 0) {
				cout << Basics[number] << endl;
			}
			else if (basics == 0) {    
				cout << CarryOn[carryOns] << endl;
			}
			else {
				cout << CarryOn[carryOns] << " " << Basics[basics] << endl;
			}
		}
		else {
			if (input.length() > 4) {
				string tempHandle;
				int output = 0;
				int i;
				for (i = 0; i < input.length(); ++i) {
					if (input[i] == ' ') {
						output += (strToNum[tempHandle] * 13);
						tempHandle.clear();
						break;
					}
					tempHandle += input[i];
				}
				i++; //跳过空格
				for (; i < input.length(); ++i) {
					tempHandle += input[i];
				}
				output += (strToNum[tempHandle]);
				cout << output << endl;
			}
			else {
				//单个的情况
				int i;
				for (i = 0; i < 13; ++i) {
					if (input == Basics[i]) {
						cout << strToNum[input] << endl;
						break;
					}
				}
				if (i == 13) {
					cout << strToNum[input] * 13 << endl;
				}
			}
		}
	}
	system("PAUSE");
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值