People often have a preference among synonyms of the same word. For example, some may prefer "the police", while others may prefer "the cops". Analyzing such patterns can help to narrow down a speaker's identity, which is useful when validating, for example, whether it's still the same person behind an online avatar.
Now given a paragraph of text sampled from someone's speech, can you find the person's most commonly used word?
Input Specification:
Each input file contains one test case. For each case, there is one line of text no more than 1048576 characters in length, terminated by a carriage return \n
. The input contains at least one alphanumerical character, i.e., one character from the set [0-9 A-Z a-z
].
Output Specification:
For each test case, print in one line the most commonly occurring word in the input text, followed by a space and the number of times it has occurred in the input. If there are more than one such words, print the lexicographically smallest one. The word should be printed in all lower case. Here a "word" is defined as a continuous sequence of alphanumerical characters separated by non-alphanumerical characters or the line beginning/end.
Note that words are case insensitive.
Sample Input:
Can1: "Can a can can a can? It can!"
Sample Output:
can 5
解题思路:
单词由大小写字母和数字组成,那我们以除字母数字外的字符为断点,利用map得到各个单词的数目
这里有两个注意点
1.统计单词的是整句话,不是就统计引号内,就如案例中那样,统计的是Can1: "Can a can can a can? It can!"整句话而不是"Can a can can a can? It can!"引号里的内容
2.最后一个测试用例是输入一串由纯字母数字组成的句子,没有其余的字符,这时在程序中就要进行判断,输出结果是:这句话+1
而不是0
#include<iostream>
#include<algorithm>
#include<map>
#include<string>
#include<string.h>
using namespace std;
bool check(char c) {
if (c >= '0' && c <= '9') return true;
if (c >= 'a' && c <= 'z') return true;
if (c >= 'A' && c <= 'Z') return true;
return false;
}
int main() {
map<string, int> alphaTable;
string input;
string tempHandle;
getline(cin, input);
bool flag = false;
for (int i = 0; i < input.length()+1; ++i) {
if (!check(input[i]) || i == input.length()) { //如果仅仅输入一个单词,没有空行,则把这个单词也统计进去
if (tempHandle.length() == 0) {
continue;
}
auto itr = alphaTable.find(tempHandle);
if (itr == alphaTable.end()) { //没找到
alphaTable[tempHandle] = 1;
}
else { //找到了
alphaTable[tempHandle]++;
}
tempHandle.clear();
}
else {
tempHandle += tolower(input[i]);
}
}
string res;
int MAX = 0;
for (auto itr = alphaTable.begin(); itr != alphaTable.end();++itr) {
if (itr->second >= MAX) {
if (itr->second == MAX) {
res = strcmp(res.c_str(), itr->first.c_str()) < 0 ? res : itr->first;
}
else if (itr->second > MAX) {
res = itr->first;
MAX = itr->second;
}
}
}
cout << res << " " << MAX << endl;
system("PAUSE");
return 0;
}