(PAT) 1022 Digital Library (利用映射map存储数据,以及输入输出控制)

A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigned an unique 7-digit number as its ID. Given any query from a reader, you are supposed to output the resulting books, sorted in increasing order of their ID's.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤10​4​​) which is the total number of books. Then N blocks follow, each contains the information of a book in 6 lines:

  • Line #1: the 7-digit ID number;
  • Line #2: the book title -- a string of no more than 80 characters;
  • Line #3: the author -- a string of no more than 80 characters;
  • Line #4: the key words -- each word is a string of no more than 10 characters without any white space, and the keywords are separated by exactly one space;
  • Line #5: the publisher -- a string of no more than 80 characters;
  • Line #6: the published year -- a 4-digit number which is in the range [1000, 3000].

It is assumed that each book belongs to one author only, and contains no more than 5 key words; there are no more than 1000 distinct key words in total; and there are no more than 1000 distinct publishers.

After the book information, there is a line containing a positive integer M (≤1000) which is the number of user's search queries. Then M lines follow, each in one of the formats shown below:

  • 1: a book title
  • 2: name of an author
  • 3: a key word
  • 4: name of a publisher
  • 5: a 4-digit number representing the year

Output Specification:

For each query, first print the original query in a line, then output the resulting book ID's in increasing order, each occupying a line. If no book is found, print Not Found instead.

Sample Input:

3
1111111
The Testing Book
Yue Chen
test code debug sort keywords
ZUCS Print
2011
3333333
Another Testing Book
Yue Chen
test code sort keywords
ZUCS Print2
2012
2222222
The Testing Book
CYLL
keywords debug book
ZUCS Print2
2011
6
1: The Testing Book
2: Yue Chen
3: keywords
4: ZUCS Print
5: 2011
3: blablabla

Sample Output:

1: The Testing Book
1111111
2222222
2: Yue Chen
1111111
3333333
3: keywords
1111111
2222222
3333333
4: ZUCS Print
1111111
5: 2011
1111111
2222222
3: blablabla
Not Found

解题思路:

我们使用 map<string, set<int>>这种数据结构来存储数据,比如现在有3个人(编号1001,1002,1007)姓名均为Mike,那么当查询所有姓名为mike的人的编号时,输出1001,1002,1007,这样只需遍历这个集合就可以获取所有姓名为mike的人的编号。

使用Map["Mike"].insert(1001) 就可以实现加入

接下来是读入数据的问题

使用cin读取字符串的话,空格会被当成结束符,所以如果输入The Testing book的话,cin只会读入The

要读入空格的话,必须使用getline(cin,string)

同时,在用scanf()读取数据后,必须用getchar()将换行吸收掉,否则getline会把换行读入

关于这题,创建5个map存储对应的ID,然后根据用户的输入数据查询即可

#include<iostream>
#include<algorithm>
#include<map>
#include<string.h>
#include<string>
#include<set>
using namespace std;
map<string, set<int>> titleMap, authorMap, keyWordsMap, publisherMap, publisherYearMap;  //存5张map
void searchInfo(map<string, set<int>>& MAP, string& content) {
	if (MAP.find(content) == MAP.end()) {
		cout << "Not Found" << endl;
	}
	else {
		for (auto itr = MAP[content].begin(); itr != MAP[content].end(); ++itr) {
			printf("%07d\n", *itr);
		}
	}
}
int main() {
	int N, M;
	char c; //用来吸收掉空格
	scanf("%d", &N);
	for (int i = 0; i < N; ++i) {
		string input;
		int ID;
		scanf("%d", &ID);
		c = getchar();
		getline(cin, input);
		titleMap[input].insert(ID);
		getline(cin, input);
		authorMap[input].insert(ID);
		while (cin >> input) {
			keyWordsMap[input].insert(ID);
			c = getchar();
			if(c == '\n') break;  //如果是换行的话,退出
		}
		getline(cin, input);
		publisherMap[input].insert(ID);
		getline(cin, input);
		publisherYearMap[input].insert(ID);
	}
	scanf("%d", &M);
	for (int i = 0; i < M; ++i) {
		int queryId;
		string queryContent;
		scanf("%d: ", &queryId);
		getline(cin, queryContent);
		cout << queryId << ": " << queryContent << endl;
		switch (queryId)
		{
		case 1:
			searchInfo(titleMap, queryContent);
		break;
		case 2:
			searchInfo(authorMap, queryContent);
		break;
		case 3:
			searchInfo(keyWordsMap, queryContent);
		break;
		case 4:
			searchInfo(publisherMap, queryContent);
		break;
		case 5:
			searchInfo(publisherYearMap, queryContent);
		break;
		default:
			break;
		}
	}
	system("PAUSE");
	return 0;
}

 

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。 经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。 经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。 经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。
1. 智慧监狱概述 智慧监狱的建设背景基于监狱信息化的发展历程,从最初的数字化监狱到信息化监狱,最终发展到智慧监狱。智慧监狱强调管理的精细化、监管的一体化、改造的科学化以及办公的无纸化。政策上,自2017年以来,司法部连续发布了多项指导性文件,推动智慧监狱的建设。 2. 内在需求与挑战 智慧监狱的内在需求包括数据应用与共享的不足、安防系统的单一功能、IT架构的复杂性、信息安全建设的薄弱以及IT运维的人工依赖。这些挑战要求监狱系统进行改革,以实现数据的深度利用和业务的智能化。 3. 技术架构与设计 智慧监狱的技术架构包括统一门户、信息安全、综合运维、安防集成平台和大数据平台。设计上,智慧监狱采用云计算、物联网、大数据和人工智能等技术,实现资源的动态分配、业务的快速部署和安全的主动防护。 4. 数据治理与应用 监狱数据应用现状面临数据分散和共享不足的问题。智慧监狱通过构建数据共享交换体系、数据治理工具及服务,以及基于数据仓库的数据分析模型,提升了数据利用效率和决策支持能力。 5. 安全与运维 智慧监狱的信息安全建设涵盖了大数据应用、安全管理区、业务区等多个层面,确保了数据的安全和系统的稳定运行。同时,综合运维平台的建立,实现了IT系统的统一管理和自动化运维,提高了运维效率和系统的可靠性。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值