(PAT 1056) Mice and Rice (队列+模拟)

Mice and Rice is the name of a programming contest in which each programmer must write a piece of code to control the movements of a mouse in a given map. The goal of each mouse is to eat as much rice as possible in order to become a FatMouse.

First the playing order is randomly decided for N​P​​ programmers. Then every N​G​​ programmers are grouped in a match. The fattest mouse in a group wins and enters the next turn. All the losers in this turn are ranked the same. Every N​G​​ winners are then grouped in the next match until a final winner is determined.

For the sake of simplicity, assume that the weight of each mouse is fixed once the programmer submits his/her code. Given the weights of all the mice and the initial playing order, you are supposed to output the ranks for the programmers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N​P​​ and N​G​​ (≤1000), the number of programmers and the maximum number of mice in a group, respectively. If there are less than N​G​​ mice at the end of the player's list, then all the mice left will be put into the last group. The second line contains N​P​​ distinct non-negative numbers W​i​​ (i=0,⋯,N​P​​−1) where each W​i​​ is the weight of the i-th mouse respectively. The third line gives the initial playing order which is a permutation of 0,⋯,N​P​​−1 (assume that the programmers are numbered from 0 to N​P​​−1). All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the final ranks in a line. The i-th number is the rank of the i-th programmer, and all the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:

11 3
25 18 0 46 37 3 19 22 57 56 10
6 0 8 7 10 5 9 1 4 2 3

Sample Output:

5 5 5 2 5 5 5 3 1 3 5

解题思路:

这题想了一个下午,不过最后还是没有看题解做出来了

给出NP只老鼠的质量,根据第二列给出的序列排序,按这个顺序把这些老师按照NG分为一组,最后不够NG的单独分为一组

选出它们之中质量大的老鼠晋级,把所有晋级的老鼠再按照NG分组开始第二轮比较

直到最后晋级出唯一一只老鼠

把老鼠的序列入队,每次比较时按照 老鼠数组[序列].重量 这样的写法互相进行比较就行,不用再单独分一个数组出来

每轮分组的组数可以根据下面这个公式得到

int temp = NP;  
int group = temp % NG == 0 ? temp / NG : temp / NG + 1;

#include <iostream>
#include <algorithm>
#include <queue>
#include <vector>
using namespace std;
struct Mouse {
	int Order;
	int Weight;
}Mice[1001];
queue<int> MiceQueue;   //按照队列排序
bool weightCmp(int a, int b) {
	return Mice[a].Weight > Mice[b].Weight;
}
int main() {
	int NP, NG;
	scanf("%d %d", &NP, &NG);
	for (int i = 0; i < NP; ++i) {
		scanf("%d", &Mice[i].Weight);
	}
	for (int i = 0; i < NP; ++i) {
		int order;
		scanf("%d", &order);
		MiceQueue.push(order);
	}
	int temp = NP;  
	int group = temp % NG == 0 ? temp / NG : temp / NG + 1;
	while (!MiceQueue.empty()) {
		for (int i = 1; i <= group; ++i) {
			int k = NG;
			if (i == group) k = temp % NG == 0 ? NG : temp % NG;
			int MAX = 0;
			int MAXSerise;
			for (int j = 0; j < k; ++j) {
				if (Mice[MiceQueue.front()].Weight > MAX) {
					MAX = Mice[MiceQueue.front()].Weight;
					MAXSerise = MiceQueue.front();
				}
				Mice[MiceQueue.front()].Order = group + 1;  //每轮淘汰的老鼠把排名设置为group+1
				MiceQueue.pop();
			}
			MiceQueue.push(MAXSerise);
		}
		if (MiceQueue.size() == 1) {  //最后一只老鼠就是第一名
			Mice[MiceQueue.front()].Order = 1;
			MiceQueue.pop();
		}
		temp = group;
		group = temp % NG == 0 ? temp / NG : temp / NG + 1;  //得到下一轮的组数
	}
	for (int i = 0; i < NP; ++i) {
		printf("%d", Mice[i].Order);
		if (i < NP - 1) printf(" ");
	}

	system("PAUSE");
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值