(PAT 1076) Forwards on Weibo (图的广度优先遍历,控制遍历层数)

Weibo is known as the Chinese version of Twitter. One user on Weibo may have many followers, and may follow many other users as well. Hence a social network is formed with followers relations. When a user makes a post on Weibo, all his/her followers can view and forward his/her post, which can then be forwarded again by their followers. Now given a social network, you are supposed to calculate the maximum potential amount of forwards for any specific user, assuming that only L levels of indirect followers are counted.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤1000), the number of users; and L (≤6), the number of levels of indirect followers that are counted. Hence it is assumed that all the users are numbered from 1 to N. Then N lines follow, each in the format:

M[i] user_list[i]

where M[i] (≤100) is the total number of people that user[i] follows; and user_list[i] is a list of the M[i] users that followed by user[i]. It is guaranteed that no one can follow oneself. All the numbers are separated by a space.

Then finally a positive K is given, followed by K UserID's for query.

Output Specification:

For each UserID, you are supposed to print in one line the maximum potential amount of forwards this user can triger, assuming that everyone who can view the initial post will forward it once, and that only L levels of indirect followers are counted.

Sample Input:

7 3
3 2 3 4
0
2 5 6
2 3 1
2 3 4
1 4
1 5
2 2 6

Sample Output:

4
5

解题思路:

题目的意思是,给出N行数据,表示第i位用户关注的用户是哪几位,最后一行给出K位用户的ID,求这些用户发表一篇微博的话,能被多少人转发(也就是入度关系网),广度优先遍历的层数必须<=L

运用广度优先遍历求用户数即可,难点是怎么控制层数

只需给每位用户设置一个层数属性,遍历完一个用户后,使和这个用户有入度关系的用户的层数+1,如果当前遍历的用户的层数>L,则不计入总数

#define _CRT_SECURE_NO_WARNINGS
#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
using namespace std;
const int MAXN = 10001;
int queries[MAXN];
struct Node {
	int id;
	int layer;
	Node(int _id, int _layer) {
		id = _id;
		layer = _layer;
	}
};
queue<Node> BFS_Queue;
class Graph
{
public:
	int n;
	vector<int> *edges;
	bool* visited;
public:
	Graph(int input_n) {
		n = input_n;
		edges = new vector<int>[n];
		visited = new bool[n];
		memset(visited, 0, n);
	}
	void ginsert(int x, int y) {
		edges[x].push_back(y);   //单向连通图
	}
};
int main() {
	int N, L, index = 0;
	cin >> N >> L;
	Graph socialCla(N+1);
	int FollowerID = 1;
	while (FollowerID <= N) {
		int num, follower;
		cin >> num;
		for (int i = 0; i < num; ++i) {
			cin >> follower;
			socialCla.ginsert(follower, FollowerID);
		}
		FollowerID++;
	}
	int K;
	cin >> K;
	for (int i = 0; i < K; ++i) {
		cin >> queries[i];
	}
	//广度优先遍历
	for (int j = 0; j < K; ++j) {
		memset(socialCla.visited, 0, N + 1);
		int node = queries[j];
		socialCla.visited[node] = true;
		int counts = 0;
		int layers = 1;
		BFS_Queue.push({ node,layers });
		while (!BFS_Queue.empty()) {
			int tempNode = BFS_Queue.front().id;
			int curLayer = BFS_Queue.front().layer;
			BFS_Queue.pop();
			for (int adj_node : socialCla.edges[tempNode]) {
				if (!socialCla.visited[adj_node] && curLayer <= L) {
					socialCla.visited[adj_node] = true;
					BFS_Queue.push({ adj_node,curLayer + 1 });   //使下一层用户的层数属性+1
					counts++;
				}
			}
		}
		cout << counts << endl;
	}
	system("PAUSE");
	return 0;
}

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值