(PAT 1126) Eulerian Path (欧拉图/欧拉回路判断)

In graph theory, an Eulerian path is a path in a graph which visits every edge exactly once. Similarly, an Eulerian circuit is an Eulerian path which starts and ends on the same vertex. They were first discussed by Leonhard Euler while solving the famous Seven Bridges of Konigsberg problem in 1736. It has been proven that connected graphs with all vertices of even degree have an Eulerian circuit, and such graphs are called Eulerian. If there are exactly two vertices of odd degree, all Eulerian paths start at one of them and end at the other. A graph that has an Eulerian path but not an Eulerian circuit is called semi-Eulerian. (Cited from https://en.wikipedia.org/wiki/Eulerian_path)

Given an undirected graph, you are supposed to tell if it is Eulerian, semi-Eulerian, or non-Eulerian.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 2 numbers N (≤ 500), and M, which are the total number of vertices, and the number of edges, respectively. Then M lines follow, each describes an edge by giving the two ends of the edge (the vertices are numbered from 1 to N).

Output Specification:

For each test case, first print in a line the degrees of the vertices in ascending order of their indices. Then in the next line print your conclusion about the graph -- either EulerianSemi-Eulerian, or Non-Eulerian. Note that all the numbers in the first line must be separated by exactly 1 space, and there must be no extra space at the beginning or the end of the line.

Sample Input 1:

7 12
5 7
1 2
1 3
2 3
2 4
3 4
5 2
7 6
6 3
4 5
6 4
5 6

Sample Output 1:

2 4 4 4 4 4 2
Eulerian

Sample Input 2:

6 10
1 2
1 3
2 3
2 4
3 4
5 2
6 3
4 5
6 4
5 6

Sample Output 2:

2 4 4 4 3 3
Semi-Eulerian

Sample Input 3:

5 8
1 2
2 5
5 4
4 1
1 3
3 2
3 4
5 3

Sample Output 3:

3 3 4 3 3
Non-Eulerian

解题思路:

欧拉图:所有顶点的度都是偶数度,存在欧拉回路:存在两个奇数度顶点,只有两个

同时,这个图必须是连通图!!!

判断这个图是欧拉图或有没有欧拉回路,首先要去判断这个图是否连通,利用深度优先遍历求连通分量就可以了

#include <iostream>
#include <vector>
#include <queue>
#include <algorithm>
#include <string.h>
using namespace std;
const int MANX = 510;
vector<int> EEdges[MANX];
vector<int> Edegress;
bool visited[MANX] = { false };
int countsF = 0;

void DFS_E(int vertex) {
	visited[vertex] = true;
	for (int adj_vertex : EEdges[vertex]) {
		if (!visited[adj_vertex]) {
			DFS_E(adj_vertex);
		}
	}
}
int N, M;
int main() {
	memset(visited, 0, MANX);
	cin >> N >> M;
	int nx, ny;
	for (int i = 0; i < M; ++i) {
		cin >> nx >> ny;
		EEdges[nx].push_back(ny);
		EEdges[ny].push_back(nx);
	}
	for (int i = 1; i <= N; ++i) {
		Edegress.push_back(EEdges[i].size());
		cout << EEdges[i].size();
		if (i < N) cout << " ";
	}
	cout << endl;
	for (int i = 1; i <= N; ++i) {
		if (!visited[i]) {
			DFS_E(i);
			countsF++;
		}
	}
	if (countsF > 1) {  //如果不是连通图,那么肯定不是欧拉图,也没有欧拉路径
		cout << "Non-Eulerian" << endl;
	}
	else {
		int oddsCount = 0;
		for (int i = 0; i < Edegress.size(); ++i) {
			if (Edegress[i] % 2 != 0) oddsCount++;
		}
		if (oddsCount == 0) {
			cout << "Eulerian" << endl;
		}
		else if (oddsCount == 2) {
			cout << "Semi-Eulerian" << endl;
		}
		else {
			cout << "Non-Eulerian" << endl;
		}
	}
	system("PAUSE");
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值