(PAT 1150) Travelling Salesman Problem (模拟旅行商问题(NP))

The "travelling salesman problem" asks the following question: "Given a list of cities and the distances between each pair of cities, what is the shortest possible route that visits each city and returns to the origin city?" It is an NP-hard problem in combinatorial optimization, important in operations research and theoretical computer science. (Quoted from "https://en.wikipedia.org/wiki/Travelling_salesman_problem".)

In this problem, you are supposed to find, from a given list of cycles, the one that is the closest to the solution of a travelling salesman problem.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (2<N≤200), the number of cities, and M, the number of edges in an undirected graph. Then M lines follow, each describes an edge in the format City1 City2 Dist, where the cities are numbered from 1 to N and the distance Dist is positive and is no more than 100. The next line gives a positive integer K which is the number of paths, followed by K lines of paths, each in the format:

n C​1​​ C​2​​ ... C​n​​

where n is the number of cities in the list, and C​i​​'s are the cities on a path.

Output Specification:

For each path, print in a line Path X: TotalDist (Description) where X is the index (starting from 1) of that path, TotalDistits total distance (if this distance does not exist, output NA instead), and Description is one of the following:

  • TS simple cycle if it is a simple cycle that visits every city;
  • TS cycle if it is a cycle that visits every city, but not a simple cycle;
  • Not a TS cycle if it is NOT a cycle that visits every city.

Finally print in a line Shortest Dist(X) = TotalDist where X is the index of the cycle that is the closest to the solution of a travelling salesman problem, and TotalDist is its total distance. It is guaranteed that such a solution is unique.

Sample Input:

6 10
6 2 1
3 4 1
1 5 1
2 5 1
3 1 8
4 1 6
1 6 1
6 3 1
1 2 1
4 5 1
7
7 5 1 4 3 6 2 5
7 6 1 3 4 5 2 6
6 5 1 4 3 6 2
9 6 2 1 6 3 4 5 2 6
4 1 2 5 1
7 6 1 2 5 4 3 1
7 6 3 2 5 4 1 6

Sample Output:

Path 1: 11 (TS simple cycle)
Path 2: 13 (TS simple cycle)
Path 3: 10 (Not a TS cycle)
Path 4: 8 (TS cycle)
Path 5: 3 (Not a TS cycle)
Path 6: 13 (Not a TS cycle)
Path 7: NA (Not a TS cycle)
Shortest Dist(4) = 8

解题思路:

首先判断给出的路径是不是一个环,判断依据是头节点和尾节点是否相等和每个节点是否都遍历

把输入的结点存入一个vector和一个set,如果vector首元素和尾元素相等,以及set中元素的个数等于结点中元素的个数,那么这个路径就是环

然后判断路径是否能走通,我们把每条边的边权初始化为一个近似无限大的负数,读入边权后,累加路径上的边权,如果边权大于0,那么这条路径能走通,否则不能走通

然后判断是否是简单路径,如果vector中元素个数==图中结点数+1,那么就是简单路径,否则就是普通路径

循环时依次比较,保留最小值即可

#include <iostream>
#include <algorithm>
#include <vector>
#include <set>
using namespace std;
const int MAXN = 210;
int N, M, K;
int TravelMap[MAXN][MAXN];
int INF = -1000000;
int smallestdis = 0x3fffffff, smallestPath;
int main() {
	fill(TravelMap[0], TravelMap[0] + MAXN * MAXN, INF);
	scanf("%d %d", &N, &M);
	int node1, node2, nlen;
	for (int i = 0; i < M; ++i) {
		scanf("%d %d %d", &node1, &node2, &nlen);
		TravelMap[node1][node2] = nlen;
		TravelMap[node2][node1] = nlen;
	}
	int num,nnode;
	scanf("%d", &K);
	for (int i = 0; i < K; ++i) {
		vector<int> vertexes;
		set<int> duVertexes;
		int ndistance = 0;
		scanf("%d", &num);
		for (int j = 0; j < num; ++j) {
			scanf("%d", &nnode);
			vertexes.push_back(nnode);
			duVertexes.insert(nnode);
		}
		for (int v = 0; v < vertexes.size() - 1; ++v) {
			ndistance += TravelMap[vertexes[v]][vertexes[v + 1]];
		}
		if (duVertexes.size() < N || vertexes[0] != vertexes[vertexes.size() - 1] || ndistance < 0) {
			if (ndistance < 0) {
				printf("Path %d: NA (Not a TS cycle)\n", i + 1);
			}
			else {
				printf("Path %d: %d (Not a TS cycle)\n", i + 1,ndistance);
			}
			continue;
		}
		//判断简单还是普通
		if (vertexes.size() == N+1) {
			printf("Path %d: %d (TS simple cycle)\n", i + 1, ndistance);
		}
		else if (vertexes.size() > N) {
			printf("Path %d: %d (TS cycle)\n", i + 1, ndistance);
		}
		if (ndistance < smallestdis) {
			smallestdis = ndistance;
			smallestPath = i + 1;
		}
	}
	printf("Shortest Dist(%d) = %d\n", smallestPath, smallestdis);
	system("PAUSE");
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值