Protecting the Flowers POJ - 3262(贪心+递推)

Farmer John went to cut some wood and left N (2 ≤ N ≤ 100,000) cows eating the grass, as usual. When he returned, he found to his horror that the cluster of cows was in his garden eating his beautiful flowers. Wanting to minimize the subsequent damage, FJ decided to take immediate action and transport each cow back to its own barn.

Each cow i is at a location that is Ti minutes (1 ≤ Ti ≤ 2,000,000) away from its own barn. Furthermore, while waiting for transport, she destroys Di (1 ≤ Di ≤ 100) flowers per minute. No matter how hard he tries, FJ can only transport one cow at a time back to her barn. Moving cow i to its barn requires 2 × Timinutes (Ti to get there and Ti to return). FJ starts at the flower patch, transports the cow to its barn, and then walks back to the flowers, taking no extra time to get to the next cow that needs transport.

Write a program to determine the order in which FJ should pick up the cows so that the total number of flowers destroyed is minimized.

Input

Line 1: A single integer N 
Lines 2.. N+1: Each line contains two space-separated integers, Ti and Di, that describe a single cow's characteristics

Output

Line 1: A single integer that is the minimum number of destroyed flowers

Sample Input

6
3 1
2 5
2 3
3 2
4 1
1 6

Sample Output

86

Hint

FJ returns the cows in the following order: 6, 2, 3, 4, 1, 5. While he is transporting cow 6 to the barn, the others destroy 24 flowers; next he will take cow 2, losing 28 more of his beautiful flora. For the cows 3, 4, 1 he loses 16, 12, and 6 flowers respectively. When he picks cow 5 there are no more cows damaging the flowers, so the loss for that cow is zero. The total flowers lost this way is 24 + 28 + 16 + 12 + 6 = 86

解题思路:

根据吃花时间/运送时间的比值来确定优先级,比值大说明造成的损失越大,应该先运送

由于运送过程中直接计算其他cow的破坏量,会超时(100000*100000),所以要通过递推法,累加当前总时间*当前cow得Di,最后得到结果。

#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <math.h>
#include <stdio.h>
using namespace std;
const int MAXN = 100010;
int N;
struct ECow{
	int Ti;
	int Di;
	double TDRate;
}ECows[MAXN];
bool ECmp(ECow a, ECow b) {
	return a.TDRate > b.TDRate;
}
int main() {
	while (~scanf("%d", &N)) {
		long long res = 0;
		for (int i = 0; i < N; ++i) {
			scanf("%d %d", &ECows[i].Ti, &ECows[i].Di);
			ECows[i].TDRate = 1.0*ECows[i].Di / ECows[i].Ti;
		}
		sort(ECows, ECows + N, ECmp);  //先排序
		long long aggtime = 0;
		for (int i = 0; i < N; ++i) {
			res += ECows[i].Di * aggtime;
			aggtime += ECows[i].Ti * 2;  //需要的时间
		}
		printf("%lld\n", res);
		
	}
	system("PAUSE");
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值