题目简要:
Description
计算组合数。C(n,m),表示从n个数中选择m个的组合数。
计算公式如下:
若:m=0,C(n,m)=1
否则, 若 n=1,C(n,m)=1
否则,若m=n,C(n,m)=1
否则 C(n,m) = C(n-1,m-1) + C(n-1,m).
Input
第一行是正整数N,表示有N组要求的组合数。接下来N行,每行两个整数n,m (0 <= m <= n <= 20)。
Output
Sample Input
3
2 1
3 2
4 0
Sample Output
2
3
1
这道题就是按照题目给出的规律输出就好了。
解题思路:
我的思路很简单,就是用一个子函数运算,在主函数中输出就好啦。
附代码:
#include<bits/stdc++.h>
using namespace std;
int answer(int,int);
int main()
{
int n,m,i,N;
while(cin>>N)
{
for(i=0;i<N;i++)
{
cin>>n>>m;
cout<<answer(n,m)<<endl;
}
}
return 0;
}
int answer(int a,int b)
{
if(a==1||b==0||a==b)
return 1;
else
return answer(a-1,b-1)+answer(a-1,b);
}
解题感受:
这道题只要看懂题就好啦,子函数只需要按照题目给出的那样写就行了,其实并没有什么技术含量的···